I put Jolicloud on a pendrive to install it to my laptop, tried it out, didn't like it, and installed ubuntu with a CD instead. Now I want to use my pendrive for storage, so I popped it in, loaded up Gparted and formatted the drive.

Now, when I pop the pendrive into my laptop, Ubuntu thinks that Jolicloud is still on it, when Gparted says there are no partitions on the pendrive.

Screenshot: alt text What's going on, here? How can I properly format the pendrive?

  • What happens when you try to navigate the pendrive in nautilus?
    – Malabarba
    Dec 15, 2010 at 2:51
  • Did you delete all the partitions before you tried to reformat? Dec 15, 2010 at 3:20
  • +1 for including a screenshot; that really helps us understand what's going on. Dec 15, 2010 at 17:01

2 Answers 2


One thing that might be causing this is an issue with the partition labels. It should all have been erased when you erased the partitions, but maybe something failed.

Using Gparted, try creating a new (FAT32) partition in your pendrive that spans the entire available space. Then, give it a new label (whichever name you like), just as insurance. That might solve your problem.

  • I ended up creating a partition on the pendrive, then formatting it again. Linux couldn't find the pendrive after this, so I popped it into my Windows PC and it found/formatted it. Very strange. Dec 17, 2010 at 22:17

Don't worry. It's just the label of the drive that's showing up. First you must unmount it before trying to mess around with its partitions. Then, using GParted, you need to create a new partition on the unallocated space you see. Just right click on the "unallocated" space and select New to create a new partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.