I'm using Windows 7. I just lost a .vdi file (a virtual hard drive for my VM), and I'm wondering if there's a file size limit for windows which might have caused a problem. I hadn't checked the size of the file lately (I set it to dynamically size as needed), but it was 15 to 30Gb at a guess.

It wouldn't back up using Windows Backup, but is it possible Windows has just stopped recognising it because it's too big? Is there a clear upper limit on file size?

  • What's your filesystem? Is it not NTFS? – Apple II Mar 23 '13 at 1:28

If the drive with your file is formatted with NTFS (which is the default in Windows 7), then according to Wikipedia, the maximum file size is 16 TB. Even if you were to (attempt) to exceed that limit, you would simply be unable to make the file any larger. It might lead to some strange behavior in VirtualBox, but would not cause the file to disappear.

What exactly do you mean by "lost"? Have you tried doing a search on the drive for *.vdi? It seems more likely that it got accidentally deleted or moved somehow.

| improve this answer | |
  • so a problem handeling large files doesn't explain what happened to my 30 Gb file then? it also refused to back-up correctly though, and the hard drive is pre-formatted in NTFS. – Kirt Dec 17 '10 at 7:45
  • Bizarre. It does not explain where your file went; as such, don't feel obligated to mark an accepted answer quite yet. Windows Backup doesn't handle large files elegantly just because of how it stores things. It should not cause files to just disappear though. Have you tried searching the drive? – nhinkle Dec 17 '10 at 8:26
  • 1
    > it also refused to back-up correctly though Were you using the VM when you tried to do the backup(s)? It won’t be able to lock the file if you have it open, so you have to shut the VM down before backing up. – Synetech Jul 29 '12 at 20:17

As designed, the maximum NTFS file size is 16 EB (16 × 10246 bytes) minus 1 KB (1024 bytes) or 18,446,744,073,709,550,592 bytes.

As implemented, the maximum NTFS file size is 16 TB (16 × 10244 bytes) minus 64 KB (64 × 1024 bytes) or 17,592,185,978,880 bytes.

Source: Wikipedia

| improve this answer | |
  • 3
    Nothing personal, but I don't think your answer really contributes much to this question. You're basically just copying verbatim from the Wikipedia article I already linked to. A comment regarding the difference between the designed max file size and implemented max file size might have been relevant, but this answer seems unnecessary. – nhinkle Dec 15 '10 at 9:01
  • 5
    this does not justify a downvote! (i posted the exact number in bytes) – Thariama Dec 15 '10 at 9:26
  • 1
    Agreed. While the answer maybe could have been more informative ("They didn't feel the need to implement such a high maximum file size when the current one is still bigger than almost any single drive on the market, let alone when NTFS was first implemented") it provides the exact answer to the question "What's the upper limit on file size?" – Shinrai Dec 15 '10 at 15:35
  • 4
    If this had been the first answer to the question, I would have upvoted it and edited it to add a bit more information. I only downvoted because it was duplicating the existing answer without contributing anything new. – nhinkle Dec 15 '10 at 20:52

Sounds like the filesystem lost the link to the file on your HDD, you should try using chkdsk.

| improve this answer | |

If filesystem of your disk drive is NTFS, 30Gb file size shouldn't be a problem. Do check drive for filesystem errors with chkdsk.

| improve this answer | |

Answering the question as asked, yes, there is a file size limit on any file system. For FAT/FAT32 partitions with normal sector/cluster sizes, it's about 4GB. For NTFS (again, with normal sector/cluster sizes), it varies--I've seen claims that Windows XP and higher can theoretically handle files as large as 16TB or even larger; I'll update this in a few more years when hard drive technology reaches the point we can test that theory.. :-D

So, answering what the OP really meant to ask.. Any issues with your *.vdi are more likely related to you virtual machine software and/or any supplementary software you use to manage the file rather than with the file system or OS. (I run WinXP Pro 32-bit/SP3 with an Oracle VirtualBox installation with a little over 150GB virtual disk image/file, far more than the 15-30GB the OP has issues with, and have had no issues with such a large disk image file.)

Also, note that any issues might even be related to disk failure or available/corrupted RAM memory--Managing a virtual disk requires keeping various data about the disk in RAM for "quick" access (quick here means not having to wait for 10-15 seconds while the VM searches the virtual disk for even a single-byte sized file..), and most issues I've seen with VM's are related to those data structures getting corrupted in RAM (and then the corrupted data written back out to the disk file!)--So backup often!

| improve this answer | |
  • One never has to search an entire disk, virtual or otherwise, to find a file. Files are found by names that are stored in special files called directories, which are organized in a tree structure. Directories and other key structures are indeed cached in RAM (both in VMs and real ones) to cut down the time it takes to read these things but even without the caches it's very very far from order-n time. – Jamie Hanrahan Apr 7 '16 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.