2

This seems to happen randomly. I changed it to top reply and place signature immediately below my reply. Any ideas on why it truncates my response and forward messages? And it does not seem to do it consistently.

Thunderbird 3.1.9 is running on Windows 7 (x64). This same behavior is exhibited on 3 different computers.

2

Google shows this question asked hundreds of times. There are many work-arounds and bug reports on this.

However it isn't a bug. It's a feature. The feature is intended to truncate unwanted signatures from Usenet (forum) posts. The signature is signified by a double hyphen and a space on a line by itself "-- ".

You can turn this feature off in Thunderbird's configuration by:

Advance -> Config Editor -> [I'll be careful] -> (search for) mail.strip_sig_on_reply -> [toggle it to false].

By the way, I spend about an hour searching for how to do this on every Thunderbird install. Hopefully this definitive answer will save Thunderbird users time.

1

From Reply message truncated Thunderbird 3.0 :

Backup your Thunderbird Profile then compact all folders.

If it doesn't resolve the problem then do the following :

Close Thunderbird. Find and delete all of the files with the .msf file extension in profile folder/Mail, including your Folders (especially if you are using the global inbox). You must have How to show hidden files and folders and if you are using Windows you also need to set "hide extensions for known file types" off (just below View Hidden). These are your mail summary files and do not hold any messages themselves. They will be rebuilt the next time you open each folder in Thunderbird. Compact all your folders when you have completed this.

If this doesn't help, please let me know your Thunderbird version and operating system.

  • updated main post with this info – Tone Apr 16 '11 at 10:35
  • I understand that none of the above helped in any way ? See also the solution at the end of how do i show full original message in reply. – harrymc Apr 16 '11 at 13:09
  • @tone You're having the problem because of the default setting is to exclude the signature indicated by two hyphens and a space "-- ". You can change this default as indicated here. from true to false. This works for all versions of Thunderbird on all platforms. You can play with workarounds that might work sometimes. Changing this setting will work all the time consistently. – L. D. James Nov 16 '17 at 16:51
  • @L.D.James: Thanks for pitching in, but this post dates from 2010 and the poster probably has resolved his problem years ago (and didn't bother to indicate what worked for him). – harrymc Nov 16 '17 at 20:15
  • I'm sure you're right about the poster. My message is to the community so that anyone running into this thread will have a working resolution. Reading all the answers there are a lot of maybe's of things that might work. I was just reiterating the certainty that would never fail. Hopefully, the Thunderbird developers will eventually put this option in the preference instead of where it's hidden. They should also remove it from the default, since many people not familiar with mail list and only use it for email won't understand or care for the feature. – L. D. James Nov 16 '17 at 20:38
1

I think this is the gmail-like "quote only what is selected" feature, not a problem. Be sure to not have anything selected before replying, if you want to quote everything.

Another option is that there is the text "--" somewhere in the message, which could be interpreted as "beginning of a signature": by default, Thunderbird do not quote anything after that. So the workaround in this case is to "select all" and the reply. In this case Thunderbird will use the feature described in the previous paragraph and quote everything, even if happens after a signature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.