10

This has happened to me one too many times last night. I walked over to my PC at 6AM and it wants me to log in. Why? Because Windows Update automatically rebooted my PC without my permission last night. At least give me the option to clean up my work and note what I have open and need to reopen.. It doesnt happen EVERY 2nd Tuesday, when Microsoft issues its out-of-band security updates, but it happened again last night and I need to find a way to stop it because it drives me batty.

I generally have a LOT of windows and browsers going, which, after one of these updates, its all lost. I am not talking about lost data. I am talking about me losing time in trying to figure out just where I was. Its 10am and I am still remembering that I had a particular browser open to a certain window or was editing a specific file in Textpad..

Any way to stop this unwanted reboot? I will manually reboot when I am ready to - like most of the other Windows Updates politely allow me to. I am running Windows 7 Ultimate 64-bit.

5 Answers 5

10

In Group Policy you can do something like that

To start group policy editor : Start / Run / gpedit.msc

Then / Computer Configuration / Administrative Templates / Windows Components / Windows Update

under there is a option like "No auto-restart with logged on users for scheduled automatic updates installations"

if not, you can set it to Enable. So it will inform you with tiny pop-up about restart but do nothing until you click it.

2
  • 2
    I am hoping this is it. I just made the change. Wont know until it happens again next month and that is IF there is a security update.
    – Taptronic
    Commented Dec 15, 2010 at 15:18
  • Note that "Windows Components" is under "Administrative Templates"
    – rakslice
    Commented Feb 21, 2013 at 5:41
3

My answer will depend on a couple of things

  • Are you on a network that sets policies.
  • Are you an do you have administrator rights to this computer.

If the Answers were in the order of "No" and then "Yes", the following fix might help you.

  1. Type "gpedit.msc" in the search box in the start menu
  2. In the window that shows, select "Administrator Templates" under "Computer Configuration"
  3. Expand "Windows Components" and find "Windows Update"
  4. Edit the "No auto-restart..." option

For more information see http://support.microsoft.com/kb/328010

1
  • @Optimal Solutions, that can happen when people answer the question at the same time.
    – Paul
    Commented Dec 15, 2010 at 17:10
2

Go to Windows Update / Change Settings, you're probably set at the default action of Install updates automatically. Change that to one of the other settings and it will resolve your problem.

1
  • Yeah, I like to go through the list of new updates and click that Install Updates button myself. Always install everything, but like to know what's coming in and to do it when I want to.
    – Svish
    Commented Dec 15, 2010 at 18:41
1

Set Windows Update to download but not install updates until you tell it to.

1
  • I have that option set since installation. During normal Windows Update notifications, I will do the install and it will give me the option to reboot now, or notify me in 10 min or 4 hours - etc.. But it still reboots on the 2nd Tuesday security update during the night.
    – Taptronic
    Commented Dec 15, 2010 at 15:17
0

On a sidenote: in order to automatically save your open tabs in your browser, and your open documents in your text editor, use Firefox with Session Saver (add-on), and Notepad++ for tabbed text editing with automatically saved sessions.

1
  • 1
    Yes, Firefox was a good friend and restored my tabs. Texpad - no. the 2 PDF's I had open, I had to remember which ones they were. Chrome, no. IE, no. And Safari, no. Lost the tabs on all of those other browsers.
    – Taptronic
    Commented Dec 16, 2010 at 1:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .