So, just took an unused HP Compaq T5000 out of storage, originally bought in 2006, so thought I'd power it up and look into how I could repurpose it at home.... except that it wont start up :(

When I put in the power supply, the green LED at front lit up momentarily, then died. Pressing the power button, and press and holding the power button don't do anything. So two things crossed my mind- the first, that perhaps the CMOS battery inside is dead (after all, it was purchased over 4 years ago), the second that the power button itself is faulty.

I have no prior experience with the unit- I'm hoping someone out there with a bit of experience with it can clarify these two things for me

i. Power Button.

The power button seems a little unusual to me, in the sense that its depressed on the left hand side, with the right hand side press-able. So I'm assuming that the power button is press, as opposed to push based, is this correct? (That is, one press powers up, one press powers down with the button depression staying the same as opposed to push in and latch to power up, push in and unlatch to power down). The reason I ask this is that it simply could be possible that the power button is broken.

ii. CMOS Battery

Can a dead CMOS battery prevent boot? There is instructions for replacing the 3v Lithium battery in the user guide, so I'm assuming that its assumed that it will die at some point- I do not know how CMOS fits into the device architecture, so I'm only guessing here.

Looking forward to your advice!


  1. Your question is not clear, it is a press type button, not a click type.

  2. No, it will not prevent power up and POST screen, but it would not be a bad idea to replace it if you get it booting.

Unplug the Power cord, Check the 120~240 volt slider switch on the PSU if it has one, slide it to 240 then back to 120. Be sure it is set to 120 before connecting it to Power, or damage will result for sure.

try another power cord

try another PSU.


  • Thanks for confirming the power button is a press type and not a click type (I'm unfamiliar with the terminology)- that rules that issue out. The power cord and adapter is the one that shipped with the unit- 12v DC 330 mA, non-adjustable. Tried a few power cords, same result- occasionally the green LED will light up, then go out. – VLostBoy Dec 16 '10 at 15:33
  • BTW- assuming you have a unit, could I bother you to confirm the power requirements? On the side of my t5000 it states "DC Rating 12V 3,33A" The PSU alongside the unit is labelled 12v 330 mA, is non-adjustable, and its labelled as an AC Adapter (which strikes me as strange) Tried a few power cords, same result- occasionally the green LED will light up (under a second), then go out again. FYI, I'm in Europe if that helps... thanks – VLostBoy Dec 16 '10 at 15:46
  • Oh it is a Laptop? If so the AC adapters are auto sensing 120~240 volt. – Moab Dec 16 '10 at 16:15
  • They have 2 ratings Input (AC) and Output (DC), this is normal. No I don't have that particular model, sorry. – Moab Dec 16 '10 at 16:30

If a CMOS battery is dead, BIOS will just ask you what time it is when the computer boots up. I have had to deal with this at the data center I work at. I don't know anything about the power button. I think you should check to make sure that the switch on the power supply is set correctly. Also, check to make sure that everything has power. I have made the mistake of missing one power cord to the motherboard more than one, and it will have a similar outcome.

-Good Luck

  • Thanks for clarifying the role of the CMOS battery- that rules that out :) – VLostBoy Dec 16 '10 at 15:27
  • Glad I could help. :D – David Dec 16 '10 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.