15

I recently switched to a new laptop running Windows 7. For some reason I am constantly getting certificate errors when hitting sites where I really shouldn't be getting them - twitter, picasa, google analytics (but gmail works), my bank, etc.

This is happening in all browsers. This is happening in all networks (at work and at home). This is definitely an issue with my laptop or operating system. I know the usual cause is my date being set incorrectly, but it's definitely correct.

The error I am getting in Chrome is the following

The site's security certificate is not trusted!

You attempted to reach www.site.com, but the server presented a certificate issued by an entity that is not trusted by your computer's operating system. This may mean that the server has generated its own security credentials, which Google Chrome cannot rely on for identity information, or an attacker may be trying to intercept your communications. You should not proceed, especially if you have never seen this warning before for this site.

I have tried manually accepting the certificate, but it doesn't work - I still get the same error every time.

I checked this answer - Endless Security Certificate Errors - and used that advice (reset my Internet settings), but it didn't make any difference.

2

7 Answers 7

8

Your problem might be that your new computer is missing some root certification authority (CA) certificates.

See this article: Windows root certificate program members

where you can manually download and install all third-party root certificates that are distributed via the Windows Root Certificate Program.

1
  • Thanks - I had about 15 root certificates where I should have had about 100. Dec 17, 2010 at 10:17
32

Be sure that the date of your computer is accurate.

A dead CMOS battery might reset the date to the early 2000 every time the computer boots which will prevent a certificate from being valid, since they have an expiration date and a validity date.

Localhost certificate with a valid date from 11/2/2012 to 11/1/2017

2
  • 1
    CMOS battery had died. I replaced it, got the security errors described in the question. Updating the system time, closing all browsers, and trying again fixed it. Thanks! May 1, 2014 at 2:02
  • 1
    I had the same problem and this was the issue! I had my date set one month ago (August instead of September) and it caused the above error! I discovered it just by chance...
    – Tomas
    Sep 8, 2014 at 16:16
2

Had the same problem on Windows 7 where any secure website would give an invalid certificate error message in any browser for Chrome, IE, and Firefox.

As a solution, I found the Browser Safeguard in my programs and deleted. No problems after that.

1
  • Similar problem on a friends computer, after uninstalling PrivDog problem solved.
    – 79E09796
    Feb 3, 2015 at 22:28
1

I'm using Windows 8 and Explorer 10

The solution may be as simple as looking on your control panel for the newest programs that were loaded most recently on the same day and deleting them. About four days ago my browser started posting an invalid certificate on every web page. Yes even the good owes like Google, Yahoo, AOL... etc. No matter what web page I went to, the invalid certificate warned me of the web page. Windows defender missed them in the scan. When you look at this issuer of the certificate it says DO_NOT_TRUST_FiddlerRoot. There we about four or five programs that were installed on the same day. Once of them was named Browser Safeguard and it was installed on the same day as the other four programs so I deleted it too then rebooted. I also went to:

Internet Explorer/Internet Options/Connections/Local Area Network (LAN) Settings and uncheck the Proxy Server box.

No more problems with invalid certificates.

0

Some antivirus overrides the root certs too. For example I had the same problem by ESET Smart Security on win7 and win8.1 systems. The solution was to turn off "SSL protocol filtering" completely.

off:

I am not sure why ESET thinks this is a good feature. I already sent and email to their support, but according to them the problem is with my system. This is interesting, since the same problem occured on 3 other computers since I sent that email. Maybe the next update will fix it.

0

With an old Notebook (Samsung N150 - win7 starter), I have successfully used the freeware version of Windows repair. I first rebooted in safe mode as told by the software and re-installed the windows version (Win7 32).

0

New laptop, exact same problem. Never encountered it before. Tried the long list of solutions offered around the web (browsing on a different computer). No joy. Then I thought of this:

  • Booted W7 on old laptop (X220, HDD, W7 Pro OEM) I've been using for many years without having seen this problem except on a highly occasional basis, probably with bona fide dodgy sites.
  • Elevated Internet Options > Content tab > Certificates button.
  • Created 4 folders on flash drive named correspondingly to the 4 tabs that contained certificates: 'Intermediate Certification Authories', Trusted Root Certification Authorities', 'Trusted Publishers', and 'Untrusted Publishers.
  • Under each tab, selected the first item and pressed Shift+End to select all.
  • Dragged each of the 4 blocks of certificates from the dialogue box into each of the 4 folders I'd created.
  • Plugged flash drive into new, problematic laptop (X201, SSD, W7 Pro vanilla ISO).
  • Couldn't be bothered to research how to package multiple certificates into a single file, so underwent the repetitive tediousness of clicking the 'Import...' button every time to run the wizard to import each file individually to its proper place under the correct tab, clicking 'Yes' to every query that the system threw up. Closed dialogues. Forty-five minutes.
  • Reloaded tab containing Superuser (presumably a trustworthy site), no restarts of anything. Instant success. Can now stop just watching YouTube videos and actually browse the web again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.