1

I'm on Windows 7 but experienced this kind of trouble on Vista as well sometimes. When I want to delete a folder when I have previously accessed a subfolder of it, Windows cannot delete it and instead says that I need permissions to do that. I own the files so it can't be that. The problem will usually only go away after I close the Windows Explorer Window in which I viewed the subfolder, or alternatively, I can delete the directory tree manually from the bottom up, files first, and then deleting the empty directories works.

Now, is there a workaround to that? Some setting or policy to tell Windows not to mess around?

2 Answers 2

2

I don't have a solution to the cause of your problem but I have a suggestion to make. Recently I got irritated from all the file deletion errors and permissions that used to occur in Windows 7 and I searched on the net. I found out this nifty and very small tool called Unlocker . It bypasses all the file restrictions placed if you are the admininstrator and lets you delete as you want so if you want you can try it out........

2
  • No Problem mate... I hope it helps...
    – user57162
    Dec 20, 2010 at 0:48
  • After some problems with the 32-bit version which didn't do anything and made me post yet another question at superuser.com/questions/223881/… , it turned out that this actually works. The question remains whether all Windows 7 computers have this problem. Dec 20, 2010 at 4:21
1

Do you have an antivirus? sometimes these get stuck on a file and since they are being used you cannot delete them, the message about permissions is kind of generic in vista and 7, being display in occasions where permissions are not the problem.

2
  • 1
    I do, but the problem is with Windows, I'm quite sure. There's no problem deleting C.txt or B. The only problem is deleting A directly without deleting C or B first. Dec 20, 2010 at 0:12
  • +1 This solved my (similar) problem with this issue. Couldn't delete files because Outlook was trying (and failing) to attach them to an e-mail. Closed Outlook, problem solved. Nov 4, 2014 at 21:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .