I noticed back in August (when I got StarCraft 2) that the key combinations Ctrl+1 and Ctrl+2 didn't work. I thought this was weird because Ctrl+3 and all the other combinations worked fine (including Shift+1, and etc), so I didn't think much of it; I just shrugged it off as a SC2 bug.

Now, 4 months later, I decided to play a completely unrelated game (Dawn of War 2) and noticed the same thing: those two specific key combinations don't work. To make sure I wasn't going insane, I tried it in Chrome and a couple other applications, and alas, it didn't work.

I remember playing strategy games over the summer before StarCraft 2 and it worked fine. Any idea as to what went wrong?


Things I've tried

  • ActiveHotkeys says the key combination is not a global hotkey.
  • Tried another keyboard--still didn't work.
  • The key combinations worked in a virtual machine (tried with both Windows and Ubuntu as guests).
  • Using Ctrl+1 as a hotkey to an AutoHotKey script worked.
  • Using Ctrl+1 as the output of an AutoHotKey script didn't work.
  • I terminated all non-essential processes, and the keys still didn't work.
  • In Safe Mode, the key combinations didn't work.

I'm running out of ideas

What else could be going on? Could a program have set some kind of keyboard hook and just never released it? Is there a way for me to see the path that the input takes through the system, to perhaps see where it stops? I'm a programmer, so I'd be fine with writing some code to help me figure this out.

  • Have you tried another keyboard? It would help isolating the source of the problem (hardware or software) – Siim K Dec 20 '10 at 8:29
  • @Siim: Tried it with a completely different keyboard--still doesn't work. – Sasha Chedygov Dec 21 '10 at 0:34
  • It sounds like it was a keyboard mapping issue. Had you merged any .REG files without carefully checking the contents? – Synetech Feb 5 '12 at 20:48
  • @Syntech: Don't think so, but ActiveHotKeys should have caught that either way. I did some more reading and I found out that Windows applications can register hotkeys, but don't necessarily have to release them, so it was likely a rogue program that I just failed to catch. Either way, my Windows install was so effed in other ways that it was time for a reinstall anyway. :) – Sasha Chedygov Feb 5 '12 at 20:53
up vote 3 down vote accepted

You could try and use Signo: it can tell you which application uses a certain hotkey, though not always; and if Activehotkeys doesn't see a hook, then I don't expect Signo to either - but who knows.

For more testing, you could download VirtualBox, make a virtual machine (that is easy), install Windows on this virtual machine, and test the hotkeys there. If they still don't work, then it is probably some weird hardware thing.

  • Singo didn't help, but your VM theory worked. The key combinations worked in VMware Player with both a Windows and Ubuntu guest, interestingly enough. – Sasha Chedygov Dec 21 '10 at 5:53
  • Hmm then something strange is happening on your PC, but you can rule out hardware. Have you tried these key combinations in Safe Mode? If they work there too, it will probably be some program that is at fault. – Cerberus Dec 21 '10 at 15:29
  • The key combinations did not work in Safe Mode, strangely enough. – Sasha Chedygov Sep 11 '11 at 6:04
  • @musicreak: Hmm so it isn't specific software, and it isn't the keyboard itself that's broken. The only think I can think of is some fault in your Windows installation? But I can imagine you wouldn't want to reinstall Windows... – Cerberus Sep 11 '11 at 14:03
  • It's just weird to think that such a specific issue could be a problem with Windows. Reinstalling is a pain, but it wouldn't be that big of a deal. I'm going to try this hard drive on another computer, and see if that changes anything; my motherboard (in case it's some other piece of hardware at fault, however unlikely). If that fails, I will probably just endure this until I reinstall. It hasn't given me too much grief, only in a select few video games (which I ended up just remapping as a workaround). – Sasha Chedygov Sep 12 '11 at 7:11

The Ctrl + 1 until 0 won't work if Windows is using them for changing keyboard layouts (English, Japanese, Norwegian and so on).

Go into the Control Panel (viewed by Category) » Clock, Language and Region » Change Keyboards or other Input Methods » Keyboards and Languages tab; Change Keyboards » Advanced Key Settings » Change Key Sequence for Ctrl + 1 until 0, to Shift + Ctrl + 1 until 0 or similar, depending on what you use.

  • I had checked this before reformatting, and this was not the issue unfortunately--I did not have any additional keyboard layouts enabled. +1 for a good suggestion though, thanks. – Sasha Chedygov Feb 5 '12 at 20:32

In my case this was caused by NVidia Geforce experience. It's not listed anywhere in the program under it's keyboard shortcuts - but uninstalling Geforce experience gave me my CRTL+1-3 keys back..

Great job Nvidia..

  • This was exactly my issue. Ctrl + 1-3 weren't working, uninstalling GFE fixed it. Thanks for pointing this out! – atomicrat2552 Nov 5 '16 at 18:03
  • 3
    It seems you can fix this by disabling Share feature inside GFE. – raine Nov 7 '16 at 16:01

I uninstalled Geforce Experience v3.2.2.44 and it instantly fixed everything.

"It seems you can fix this by disabling Share feature inside GFE. – rane Nov 7 '16 at 16:01"

i did this and everything started working perfectly again. no need to uninstall geforce experience.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.