8

I'm trying to set up Mutt with GMail for the first time. It seems to work pretty well. However, when I send a mail from Mutt, it appears twice in GMail's Sent folder. (I assume it's also sent twice - I'm trying to validate that.)

My configuration (Stripped of coloring):

# A basic .muttrc for use with Gmail
# Change the following six lines to match your Gmail account details
set imap_user = "XX"
set smtp_url = "XX@gmail.com@smtp.gmail.com:587/"
set from = "XX"
set realname = "XX"

# Change the following line to a different editor you prefer.
set editor = "vim"

# Basic config, you can leave this as is
set folder = "imaps://imap.gmail.com:993"
set spoolfile = "+INBOX"
set imap_check_subscribed
set hostname = gmail.com
set mail_check = 120
set timeout = 300
set imap_keepalive = 300
set postponed = "+[Gmail]/Drafts"
set record = "+[Gmail]/Sent Mail"
set header_cache=~/.mutt/cache/headers
set message_cachedir=~/.mutt/cache/bodies
set certificate_file=~/.mutt/certificates
set move = no
set include
set sort = 'threads'
set sort_aux = 'reverse-last-date-received'
set auto_tag = yes
hdr_order Date From To Cc
auto_view text/html
bind editor <Tab> complete-query
bind editor ^T complete
bind editor <space> noop

# Gmail-style keyboard shortcuts
macro index,pager y "<enter-command>unset trash\n <delete-message>" "Gmail archive message"
macro index,pager d "<enter-command>set trash=\"imaps://imap.googlemail.com/[Gmail]/Bin\"\n <delete-message>" "Gmail delete message"
macro index,pager gl "<change-folder>"
macro index,pager gi "<change-folder>=INBOX<enter>" "Go to inbox"
macro index,pager ga "<change-folder>=[Gmail]/All Mail<enter>" "Go to all mail"
macro index,pager gs "<change-folder>=[Gmail]/Starred<enter>" "Go to starred messages"
macro index,pager gd "<change-folder>=[Gmail]/Drafts<enter>" "Go to drafts"
macro index,pager gt "<change-folder>=[Gmail]/Sent Mail<enter>" "Go to sent mail"

#Don't prompt on exit
set quit=yes


## =================
#Color definitions
## =================

set pgp_autosign
1
  • macro index,pager d "<enter-command>set trash=\"=[Gmail]/Bin\"\n <delete-message>" "Gmail delete message"
    – user1686
    Dec 21 '10 at 16:29
15

To get rid of duplicates, unset $record. Gmail's SMTP server stores the message automatically.

7

Don't save sent messages, Gmail has that function inbuilt, set record = "+[Gmail]/Sent Mail" is unnecessary (and causes the issue you describe).

6

The Gmail server automatically stores a copy of all sent mail for you, so you do not need mutt to also store a copy. You want to keep the $record setting as that allows you to view the sent folder from mutt via the < shortcut. What you want to do is to set $copy to no to disable mutt's storing of all sent mail:

set record = "+[Gmail]/Sent Mail"
set copy = no

And no, the emails were not actually sent to the recipients twice.

1
  • Upvoted for the useful tip about using < (which I didn’t know about). This is also the only answer that re-assures the OP about mails not being sent twice. Sep 21 '17 at 19:25
4

Via: http://mail.google.com/support/bin/answer.py?hl=en&answer=78892

Do NOT save sent messages on the server. If your client is sending mail through Gmail's SMTP server, your sent messages will be automatically copied to the [Gmail]/Sent Mail folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.