7

we are currently evaluating Microsoft Lync server (previously Microsoft Office Communications Server).

It talks sip over TLS (TCP 5061) with SIMPLEmessaging, what linux client would you suggest to use voice, SIMPLE (text) messaging and maybe even video with it?

Thanks G

4
  • (ps we had apparently no luck with gossip on ubuntu) Dec 21 '10 at 19:07
  • 4
    Don't get Lync! D:
    – Pylsa
    Dec 23 '10 at 22:26
  • If you can suggest any OSS alternative with: messaging / audio video conferencing / desktop sharing I'll be glad to propose it to my boss Dec 24 '10 at 6:51
  • 1
    Anyone evaluating Lync should at least take a look at the kind of support you can expect: community.office365.com/en-us/f/166/t/6903.aspx
    – Peltier
    Dec 15 '11 at 16:03
5

So far I have only had success for text only support using Pidgin with the SIPE plugin. I'm looking into SIP Communicator (which is java based and runs on all platforms) it does have some VOIP and Video support, but I have not been able to get it to connect to my company's OCS SIP server.

For Pidgin, get at least version 2.6.6 and install Pidgin-SIPE plugin version 1.8.0-1ubuntu1

  • Create a new account, selecting the "Office Communicator" protocol.
  • username is your corporate email address (joe.bloggs@yourdomain.com).
  • login is [DOMAIN][Active Directory user name].
  • password is your AD password.

it should detect your sip server automatically, however if not my best guess would be sip.yourdomain.com on port 5061

On my company's network it will only run if you disable the proxy.

2
  • mmmm no luck both with pidgin-sipe ( I get unable to resolve domain@server.domain: 11004 ) and with sip-communicator Dec 24 '10 at 9:59
  • Voice support has been added in the recent pidgin sipe version.
    – Vanuan
    Nov 18 '13 at 15:35
3

I have used both pidgin and empathy to connect to our office OCS server.

For pidgin I use the pidin-sipe package.

For empathy, you need telepathy-haze which implements a libpurple-equivalent for telepathy, as well as purple-sipe. libpurple is the IM connection manager for pidgin, so telepathy-haze enables the telepathy framework to use pidgin plugins. purple-sipe is just a reworked pidgin-sipe for the purple framework.

Both of thee support chat only. No video.

2
  • it should be noted that Empathy does not not work if the OCS/Lync server has an invalid or self-signed SSL certificate. If using Pidgin you get a dialogue box to accept the cert., but it doesn't appear that Empathy allows this.
    – Norky
    Jul 26 '11 at 14:03
  • as an addendum to my previous comment, Empathy works if you get the OCS/Lync server host SSL certificate in .pem format and store it in your host's cert repository (/etc/pki/tls/certs/ in the case of Fedora)
    – Norky
    Jul 27 '11 at 8:28
2

Using Fedora 11 I was just able to get Pidgin to do the chat-thing.

At rpm.pbone.net I was able to find the plugins I needed for Fedora 11. I first downloaded pidgin-snipe. And when I attempted to install it I was missing the dependency purple-sipe:

After I installed those two RPMs and pidgin I did the following:

  1. From the terminal I invoked pidgen
  2. I then Added a new account
  3. At the Basic tab
    • Protocol = Office Communicator
    • Username = AD-Account@tcp-domain
    • Login = AD-domain\AD-Account
    • Password =
  4. At the Advanced tab
    • Calendar source = None
  5. At the Proxy tab
    • Proxy type = No Proxy
  6. Clicked Add

Selecting "Calendar source = None" is very important.

Not the answer you're looking for? Browse other questions tagged or ask your own question.