I have a Windows 7 and an XP machine connected to a NETGEAR wireless router. Both machines can log into the network and surf the web. Both are connecting wirelessly.

I can ping the router from each machine and get a reply. I can ping each machine from the router and get a reply. But i cannot ping each machine from the other; getting a request time out.

Subnet IP Addresses are 192.168.1.* Router =1; Win7 = 10; XP = 11;

Firewall is currently off in both systems. Since i can ping from router im picking that not the problem anyway.

If i try to ping from xp to win7 i get Request Timed Out. If i try to ping from Win7 to Xp i get destination host unreachable.

What should i do now? Thanks

  • if you run ipconfig /all from both workstations does the output make sense?
    – user33788
    Commented Dec 21, 2010 at 20:05
  • Yes. The gateway for both machines are pointing at the router and all the values look right. Each machine can also ping itself. thnx
    – Anonymous
    Commented Dec 21, 2010 at 20:21
  • What about ARP tables? You can try disable/enable the connections and/or repairing the connections on both systems.
    – Khaled
    Commented Dec 21, 2010 at 20:37
  • Ok ive deleted all ARP entries and done an ipconfig /renew but still no response between systems.
    – Anonymous
    Commented Dec 21, 2010 at 20:55
  • Ive gone into the router and displayed the routing table. Althought the router IP address is in there the IP address foreach machine is not. I dont understand routing tables but shouldn;t the IP address of each machine be in the routers routing table?
    – Anonymous
    Commented Dec 21, 2010 at 21:07

2 Answers 2


k. Ive sorted the problem.

When i used some cat 5 on the XP machine i was able to ping it, but still couldn't ping to the Win7 machine. When i cat 5 the Win7 machine i could then ping that.

It was a router based setting. Wireless Isolation was enabled.

I saw it earlier but thought it meant something else but it actually means isolate the individual machines within the subnet from each other so you cant even ping machines on the same subnet. Seems an odd default but is kinda cool. ;)

Not sure if i should delete the post or not?

  • 1
    That's a great default if you're running the router in a coffee shop or something!
    – goblinbox
    Commented Jan 8, 2011 at 18:08
  • Yep. Good point.
    – rism
    Commented Jan 14, 2011 at 0:26

You'll also want to check other wireless settings on the router. For example, a D-Link router also has "WMM Enable" and "Short GI", which are intended to make the network more reliable or faster but actually caused a similar issue (and you won't know until you experiment.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .