My iPad keeps spitting out the error: "A connection could not be established to the PPP server."

I am trying to connect it to a VPN I set up with Windows 7 as an incoming connection.

On the iPad, I went into the VPN settings, added a new PPTP VPN with the following information

  • Server: Windows 7 Computer's IP RSA SecurID: OFF
  • Account: Account Username
  • Password: Account Password
  • Encryption Level: Auto
  • Send All Traffic: ON
  • Proxy: Off

Now I know that it is making some connection to the Windows 7 Computer because whenever I intentionally put in the wrong VPN password on the iPad, it makes me put in the correct one before trying to connect again.

All the ports are forwarded on my router for PPTP, and my Windows 7 Firewall is even off to try to get this to work. Any help would be greatly appreciated, thanks.

  • 1
    Usually there is also an option in the router to allow GRE/VPN traffic. If your router does not have this option - assume it's blocked and you will need a new router (or install something to make it useful like DD-WRT or Tomato). Jan 31, 2013 at 22:12
  • Try to connect to the VPN from inside the network. If it works just fine it has to be a router port forwarding issue.
    – wbeard52
    May 4, 2015 at 3:18
  • If you want to try a vpn app, download betternet fro the App Store
    – Antp
    Jun 3, 2015 at 9:47

2 Answers 2


Some ideas:

  1. Connect using the IP address instead of server's name.
  2. Turn VPN off from your settings and turn your iDevice off and then back on.
  3. Go into the Settings.app and navigate to General > Reset and click the Reset Network settings. This will delete all saved network connections but may fix the error.
  4. Use L2TP instead of PPTP. This requires installing on Windows 7 third-party software such as the open source OpenVPN project.

Wow I just tried doing the same thing last night!

Except it was from my mac to my pc server.

Same error unfortunately PPP server not found displayed on my mac.

Its a long shot but it could possibly be that your router cannot forward the GRE 47 protocol needed in addition to port 1723.

Looking for a more secure alt than PPTP now anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.