I have one of those fancy schmancy devices, which is given to me by a frustrated friend of mine.

Device is a Prestigio Leather 8GB

enter image description here

It identifies itself to Linux host as:

Bus 001 Device 006: ID 1307:0165 Transcend Information, Inc. 2GB/4GB Flash Drive

Kernel messages as USB device is plugged in:

kernel: [ 2769.580042] usb 1-9: new high speed USB device using ehci_hcd and address 7
kernel: [ 2769.714782] scsi8 : usb-storage 1-9:1.0
kernel: [ 2770.713937] scsi 8:0:0:0: Direct-Access     8192MB   flash drive      1.00 PQ: 0 ANSI: 2
kernel: [ 2770.714535] scsi 8:0:0:1: Direct-Access     8192MB   flash drive      1.00 PQ: 0 ANSI: 2
kernel: [ 2770.715734] sd 8:0:0:0: Attached scsi generic sg3 type 0
kernel: [ 2770.716108] sd 8:0:0:1: Attached scsi generic sg4 type 0
kernel: [ 2770.722175] sd 8:0:0:0: [sdc] 962560 512-byte logical blocks: (492 MB/470 MiB)
kernel: [ 2770.722657] sd 8:0:0:0: [sdc] Write Protect is on
kernel: [ 2770.731078] sd 8:0:0:1: [sdd] 14012416 512-byte logical blocks: (7.17 GB/6.68 GiB)
kernel: [ 2770.731215]  sdc:
kernel: [ 2770.738251] sd 8:0:0:1: [sdd] Write Protect is off
kernel: [ 2770.880328] 
kernel: [ 2770.885876] sd 8:0:0:0: [sdc] Attached SCSI removable disk
kernel: [ 2770.887442]  sdd: unknown partition table
kernel: [ 2771.049605] sd 8:0:0:1: [sdd] Attached SCSI removable disk

So, symptoms are typical for U3-like devices: two separate devices inside of a single flash device. Windows sees it also as two identical usb devices, and mounts two separate drives to system, whereas first one presents itself as a CDROM device, holding a write-protected content, and second is a regular flash-disk partition, that "can" be written to. However, it seems like it's broken in some weird way, since it won't let me write anything to it, format it, nothing, but that's not the issue right now.

Question: How can I unlock entire USB stick so it appears to system as a single, 8GB device which can be partitioned and used normally, without restrictions?

Since it appeared to be an U3 device, I have tried standard utilities: both U3 Uninstaller by u3.com (found on SoftPedia), and opensource u3_tool from sourceforge (on both Windows and Linux). First utility failed to even detect USB stick as U3 device (simply stood idle while I re-plugged stick several times), while second tool failed with some obscure error about SCSI command unable to do something (I might be able to provide exact errors when I switch back to windows). u3_tool -i /dev/sg3 (Display device info) fails with

u3_partition_info() failed: Device reported command failed: status 1

...and every other option fails with same error, minus first part which states which command precisely has failed.

So, apparently, this isn't a U3 device. Or, if it is, it doesn't behave like one.

I read on a few occasions that this device protection is done by special command sent to device which tells it to lock itself, and so there should be an unlock command, that would set drive straight.

Does anyone have any idea about what could I do to this device to fix it?

P.S. I also mentioned a problem with being unable to use second "drive", but I'll tackle that problem when (and if) I manage to merge those two devices into one...


I've just managed to merge the drives of an 8 GB Prestigio stick using this procedure (in Russian): www.flashboot.ru/Files-file-561.html

Here it goes:

  • Unplug the USB stick.
  • Install the UT165 MPTool utility (during the installation, it will ask which driver to install; choose AUTO-CHECK or leave the default one)
  • Run MPTool, confirm the driver installation. In the utility's menu, check Driver - Uninstall drivers (so that the special drivers required by the tool get uninstalled when it is closed)
  • Plug the USB stick. Windows will detect a new device - let it find the driver automatically. A new device "FABULK" will appear.
  • Press F3 ("Enum") in MPTool, a device will appear at one of the ports. If it didn't and you are certain that the controller is indeed the UT165, run C:\Program files\MDPT\Driver\InfUpdate.exe and specify VID and PID of your device.
  • If the device has been recognized, press Space - it will start the formatting. Watch the Status field, it should eventually become "OK". If there is an error code instead, check what it means in menu Help - Error Code List.
  • Close MPTool or uninstall it completely. This should remove the drivers for FABULK device, otherwise Windows will not recognize the USB drive.
  • Re-plug the stick
  • Format the drive with standard tools
| improve this answer | |
  • I don't have the device any more, so I can't try this. However, thank you very much for a very detailed guide. I'm sure it will come in handy someday. – mr.b Jan 2 '11 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.