I recently had a fault with my broadband connection. It turned out to be a fault with the ISP's or teleco's equipment. My ISP posted this diagnostic, but while I understand it in general, I'd like to to know more about the details.

I'm assuming that ATM means Asynchronous Transfer Mode and PPP means Point to Point Protocol. It was this that my router was indicating as the fault.

xDSL Status Test Summary
Sync Status: Circuit In Sync

General Information
NTE Status: NTE Power Status: Unknown Bypass Status:

Upstream DSL Link Information Downstream DSL Link Information
Loop Loss: 9.0 17.0
SNR Margin: 25 15
Errored Seconds: 0 0
HEC Errors: 0
Cell Count: 0 0
Speed: 448 8128
TAM Status: Successfully executed operation

Network Test: Sub-Test Results
Layer Name Value Status
Modem pass
Transmitter Power (Upstream) 12.4 dBm
Transmitter Power (Downstream) 8.8 dBm
Upstream psd -38 dBm/Hz
Downstream psd -51 dBm/Hz
DSL pass
Equipment Vendor Name TSTC
Equipment Vendor Id n/a
Equipment Vendor Revision n/a
Training Time 8 s
Num Syncs 1
Upstream bit rate 448 kbps
Downstream bit rate 8128 kbps
Upstream maximum bit rate 1108 kbps
Downstream maximum bit rate 11744 kbps
Upstream Attenuation 3.5 dB
Downstream Attenuation 0.0 dB
Upstream Noise Margin 20.0 dB
Downstream Noise Margin 19.0 dB
Local CRC Errors 0
Remote CRC Errors 0
Up Data Path interleaved
Down Data Path interleaved
Standard Used G_DMT
INP Upstream Symbols n/a
INP Upstream Delay 4 ms
INP Upstream Depth 4
INP Downstream Symbols n/a
INP Downstream Delay 5 ms
INP Downstream Depth 32
ATM Reason: No ATM cells received fail
Number of cells transmitted 30
Number of cells received 0
number of Near end HEC errors 0
number of Far end HEC errors n/a
PPP Reason: No response from peer fail
PAP authentication nottested
CHAP authentication nottested


I've just had a status update from my ISP:

The issue was with equipment and software at your local exchange which your services goes through

So no real help there in telling me whether it was a hardware or software problem.

  • Any particular bit? – Matthieu Cartier Dec 27 '10 at 12:30
  • @neurolysis - the bits that have fail next to them – ChrisF Dec 27 '10 at 18:39
  • Chris - I see your edit. That's your answer. The local exchange is the building that holds the other end of your phone line. What further answer are you looking for? They had a problem, they fixed it. What are you trying to find out, and why is this answer insufficient for you? Unless you were a telecom technician, more details won't help you out, and if you were a telecom technician, you'd be asking different questions. – mfinni Jan 5 '11 at 15:54
  • @mfinni - I was curious as to whether it was a hardware or software issue. Saying "it was at the exchange" doesn't really answer that question. – ChrisF Jan 5 '11 at 16:00
  • They claim that it's both. Why does it matter to you? If you need more details, you can keep asking them and they may or may not give you answers that matter to you. None of us work there, so we can't give you the details you're after. – mfinni Jan 5 '11 at 16:04

to put dsl broadband to the most basic level, the telephone cable comes out at the exchange and goes in to splitter equipment, half goes to the telco/phone side, other goes to the ISP.

ATM is basically a physical transfer layer, it is level 1 on the OSI model, and used as the physical link.

PtPP gets performed at the link layer, it needs a physical connection (in your case, ATM) and is basically responsible for linking your device (in this case, a router) to the endpoint within your ISP.

So, from that log, ATM tried to transmit 30 frames/cells, but none were received back - a dead connection, or no one on the other end. Because of this, no PtPP can be established.

| improve this answer | |
  • Given that there was nothing wrong with my hardware, where would have the fault been? – ChrisF Dec 27 '10 at 18:40
  • It is hard to know for certain without knowing your ISP's network, however, I would say that the problem was most likely at the local exchange as ATM is usually the earlies part of the connection. If it was within your ISP, it would most likely be ATM works but PtPP fail. The most common reason, believe it or not is network technicians unplugging incorrect cables. – William Hilsum Dec 29 '10 at 3:09
  • +1, A DSL modem communicates with DSLAM equipment, which is what the test was run on (apparently). The ATM section shows cells trasmitted, and no near end failures, so the first hop in the ATM network worked, but something later didn't. It's impossible to tell exactly where, but one can assume it was a downed link in the ISDN/SoNet/Etc network. Most of these backhauls are redundant, so it's strange that it failed, but it happens. – Chris S Dec 29 '10 at 16:50

Given that you have told us that the ISP said the fault was on their equipment, what is it that you want us to tell you? They didn't have a fault on the line, because you have modem and DSL as a "PASS", so it was somewhere in their ATM equipment, most likely.

| improve this answer | |
  • It's largely curiosity and wanting to know why something suddenly failed. – ChrisF Dec 28 '10 at 14:09
  • So ask them... Unless we worked there, we can't tell you any more than you've already been told. – mfinni Dec 28 '10 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.