55

I'd like to change the default properties of the connector tool in Visio from right-angled lines with an arrow head to curved lines without arrows at either end. Can this be done? If so, how?

10 Answers 10

48
  1. Open your diagram

  2. Menu -> File -> Shapes -> Show Document Stencil.

    New Stencil window shows up in left of screen, with lots of shapes!)

  3. Select the "Dynamic Connector"!

  4. Right mouse-click -> Edit Master -> Edit Master Shape

    Master Shape is opened for editing.

  5. Change the Line Colour, Line Thickness, Arrow Type etc!

  6. Close the Master Shape.

    You will be asked, do you want to save and update all linked items.

Notice: If you say yes, this will change the format of all of the connectors that were created using the "Dynamic Connector" This worked for me in VISIO 2007, and is not the general DEFAULT, but the default for the current document you are working on. I am guessing it can also be applied to the standard visio template, but I have not attempted that.

3
  • Although this may be helpful to a 2007 user, the answer is tagged for 2010. – zr00 Jun 20 '18 at 18:22
  • 1
    Under Visio 2013, you need to look at the Shape's Style as well. See @TwistyImpersonator's answer below. – Carl Witthoft Oct 1 '18 at 14:43
  • 1
    Modern Visio (e.g 2019) : Alt-Q -> type "Dynamic Connector", then as above. – OzBob Aug 13 '19 at 2:43
39

This is how you do it in 2010 Visio:

Go to your shapes fold out pane, mine is on the left.

Click on Document Stencil. It may be hidden so expand the listing area or scroll down if needed. You may need to click More Shapes -> Show Document Stencil.

The rest is the same as one of the other answers here for 2007:

Right click on your Dynamic connector > Edit Master > Edit Master Shape. Click on the line to select it. Then change what you will! Make sure to save your changes.

5
  • 7
    I had to click "More Shapes > Show document stencil" to find it. – Duncan Jones May 5 '15 at 7:55
  • 3
    These are also the same steps for Visio 2013 and 2016. – Holistic Developer Oct 7 '15 at 5:05
  • 2
    For 2013 Visio Standard, at least, you must have at least one connector on the drawing to get "Dynamic Connector" to show up. An alternative is to set the connector up and then drag it into the stencil you just created. Then you can just reuse it like other shapes. – MrMas Apr 19 '17 at 0:08
  • 2
    Don't use the save command - it will prompt you for a file name. Just close the design, and it will ask you if you want to save the changes. – CJ Dennis Oct 31 '17 at 11:11
  • 1
    Still works for 2016 as well. – avgvstvs Nov 27 '17 at 22:02
16

Visio 2013 and later use Themes to define the default connector. Here's how to change the Theme that affects the default connector (the one used when choosing the Connector tool on the ribbon or by pressing CTRL+3). This affects the current document only:

  1. Add the Define Styles command to the ribbon (it's not there by default):

    a. In the File menu choose Options then select Customize Ribbon in the left pane.

    b. You need a custom group in which to add the command, so below Customize the Ribbon select the entry for the Design tab then click New Group.
    enter image description here

    b. In the Choose commands from: dropdown select Commands Not in the Ribbon. enter image description here

    d. Find the command Define Styles.... Select the custom group you added in step b, then click Add > >.
    enter image description here

    e. click OK to close Visio Options.

  2. Back in the main application, on the Design tab of the ribbon in the New Group group click Define Styles.
    enter image description here

  3. In the dialog box, in the Name: drop down select Connector. In the Based on: drop down select Theme. Then click Shape....
    enter image description here

  4. Make the desired changes. In my case, I removed the arrow from the end of the connector that was being added by the document template I had chosen.

  5. Click OK to close the dialogs and you're done!

Thanks to poster jynlmb in this thread on Microsoft's Visio forum for pointing me in the right direction to discover this.

3
  • 3
    1) of all these ridiculous options, this actually worked. 2) How is this SO COMPLICATED? Microsoft needs to get their crap together! Default connector color/end shapes seems so basic for a charting tool. – EdHayes3 Aug 20 '18 at 18:12
  • 2
    FYI, Worked in Visio 2016 on Windows 10. – EdHayes3 Aug 20 '18 at 18:21
  • In Visio 2013, with an existing diagram, I had to change the underlying Style as well. "Connector" inherited from "Normal". Wish I'd seen your answer first, as that would have saved me some pain. – Carl Witthoft Oct 1 '18 at 14:42
6

Just a note, the accepted answer is 100% correct, however, when I did it in Visio 2016, the default connector was already a line with no arrows and yet every connector had a bloody arrow. I had to change it to something else, save it, go back, change it back to no arrows, and then save it again. After that the connectors were arrowless. I tried just saving after making other changes but that didn't help. I had to change it to arrows then back again after saving.

Here's how to do that:

  1. On the Developer tab of the ribbon in the Show/Hide group check Document Stencil.
  2. In the Stencils pane, select the Document Stencil stencil.
  3. Right-click the Dynamic Connector shape and choose Edit Master > Edit Master Shape.
  4. Add arrows to the shape, then exit and save it.
  5. Repeat step 3.
  6. Remove the arrows from the shape, then save it again.
3
  • Somehow, there is a way to set the default line style (applies to connector and line tool) without touching the connector stencil. I did it - I added an arrow head. But have forgotten how, and now I can't change it back. – jws Jun 12 '17 at 15:31
  • Also, I found only two ways to get the document stencil to show in the shapes pane: 1) typing 'document stencil' into the ribbon search function; 2) in the 'developer options' ribbon tab -- this tab can be enabled somewhere in file > settings. – j0057 May 7 '18 at 8:35
  • 1
    @j0057 Enable Developer tab: File menu > Options > Customize Ribbon (left pane) > check Developer under Main Tabs (right pane) – I say Reinstate Monica May 23 '18 at 13:44
2

Try changing the RouteStyle property on the Page Shape Sheet for your default template. For Jumps, Change Line Jump Code as desired.

2

If you can't successfully change the default using any of the suggestions above, a quick way to change all the arrows on your drawing to basic lines or vice versa is to use 'select by type'

  1. On the Home tab of the ribbon, in the Editing group choose Select > Select by Type

  2. In the dialog click Shape Role and check Connectors

  3. Click OK, then pick Shape Styles/Line/Arrows off the Home tab of the ribbon and select no arrows option.

Hey presto, they're all straight lines.

1
  • Selecting no arrows in the Line > Arrows menu did not work for me. Instead, I had to right-click one of the selected connectors, choose Format Shape and set the Begin and End Arrow types to None. – I say Reinstate Monica May 23 '18 at 13:56
1

I don't know if you can change the default connector type to curved one. But you can do like this: draw your diagram fully by using default right angle connector. After finishing select all the diagram by ctrl+a. Then click "Design" menu group. On the far right end there is a Connectors button. Click down arrow and select curved lines. All the connectors will convert to curved... Hope this helps...

1

Another option is to save your customized connector in a diagram to the Favorites bar. Then use that instead of connector button on the menu group.

  1. On More Shapes click Favorites.
  2. Right-click the Favorites title bar, and then click Edit Stencil.
  3. Drag your custom connector (that is curved) to the Favorites stencil.
  4. Right-click the Favorites title bar, and then click Save.
0
1

Works for Visio 2010, not sure of other versions.

  1. Turn on Developers Mode

    • Go to Tools->Options->Advanced Tab
    • Check "Run in Developers Mode" and click OK
  2. Change the default connector

    • Go to Format->Define Styles
    • Select Name: Connector in first drop-down box
    • Change Formats for connector as needed and click Apply

Credit: http://visguy.com/vgforum/index.php?topic=1070.0

1
  • This worked for me in Visio 2007. :) – cxw Mar 16 '16 at 13:04
-1

Select the connector. Find the Line menu:

image

Go to the Arrows sub menu and select style. Weight, Dashes and Line Options will also help... Line options makes curved cornes...

2
  • Thanks, but thats not exactly what i wanted. I'd like the default connector that gets drawn will already be with some specific properties without me having to set them for every new connector i make. – yurib Jan 6 '11 at 10:42
  • This changes an existing connector, but does nothing to modify the default connector, which is what the question is asking. – I say Reinstate Monica May 24 '18 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.