1

I am inserting numbered equations using tables and multi-level lists as described in http://blogs.msdn.com/b/microsoft_office_word/archive/2006/10/20/equation-numbering.aspx

I want to cross-reference the equations in my text. To do so I go to Insert->Cross reference and among the "Numbered Items" I pick the equation I wish to refer to.

The problem is that if I pick the "Insert reference to" as "Paragraph number" a zero is always inserted into my text.

The surprising thing is that the hyperlink in the cross-reference points to the correct equation. Also if I choose "Insert reference to" as "Page number" then the correct page numbers are inserted and they are correctly updated too.

1
  • 1
    I'm currently trying exactly the same thing with the same results. However, I noticed that if you right click the insterted cross reference and pressing 'edit field' there is a bunch of options you can play around with. So far I haven't succeeded though. I let you know if I do!
    – Theodor
    Dec 29 '10 at 9:53
1

This works really well so far:

  1. Click on the equation number to select it, then click Insert, Bookmark.
  2. Assign a meaningful name to the Bookmark (bookmark names should start with a letter and should not include any spaces), and click Add. Repeat this process for any equation that you wish to reference.
  3. To create a cross reference to the equation somewhere in your text, click Insert, Cross Reference.
  4. Under Reference Type select Bookmark, and from the presented list of bookmarks, choose the appropriate one. Under Insert reference to select Paragraph number (full context) and click Insert.

The full article is available here

I name my bookmarks staring with "eq_", e.g. "eq_area_of_circle".

I can then reference "eq_area_of_circle" as:

                   A = pi * r^2                               (4)

The area of the circle mentioned can be calculated using (4).
0
1

I came across the same issue exactly. Chapter, section, subsection, Figure and Table cross references worked fine, but equation numbering always came back as '0'. I discovered if I put any text after the equation number, then it worked. So the cross-reference feature in MS Word must need some text following the number for the reference to work right, I guess. I thought it was clunky at first, but I've adopted the "Bookmark" solution posted by Theodor as well.

1

Another option would be to insert an empty space after your numbers. Say you have (1) as your equation number in front of your equation. Just point your cursor after the number and press space-bar once or twice. That tricks word into believing there is some text appended to the numbered item and will show a proper cross reference to it. Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.