I'm running rxvt in Cygwin on a Windows box. This is how I invoke it:

rxvt -sr -sl 2500 -sb -geometry 90x30 -tn rxvt -fn "Lucida Console-14" -e /usr/bin/bash --login -i

Anyone know how to pause the console output in rxvt? I can use Ctrl-S / Ctrl-Q to pause / un-pause, but this won't work if a script is already running and spewing output to stdout. Highlighting the terminal window with the mouse doesn't seem to work like with other consoles such as the standard Cygwin console, or the Windows command prompt console.

Some sort of scroll lock would be nice, but I can't seem to find any way to do this. I know I could just pipe my output to a file, but I want a way to pause the output for something that I didn't expect to explode with console output. Basically I want to scroll back while its running without it constantly moving me to the bottom of the output buffer as it updates more data to stdout.

I don't particularly care if the solution given actually pauses the script (like when you highlight the mouse in the Windows Command window), or just scroll locks and let's me scroll while its still running the underlying script, though I'd like to know how to do both if its possible.


Maybe you just need to view the output without jumping back to the bottom? The -si option inhibits the jumping to bottom on tty output. At least on Linux.

  • 1
    Thanks! "-si -sw -sk" seems to be exactly what I want. It doesn't bump me to the bottom when I scroll back, it doesn't scroll when I'm looking at history, and when I press a key, it takes me to the bottom. – Javid Jamae Dec 30 '10 at 18:36
  • You might want to have a look at 'mintty', which behaves like that by default. Unlike rxvt it also offers Unicode support and a more Windows-native UI with an options dialog. – ak2 Dec 30 '10 at 22:29
  • This works with urxvt too, however I've noticed something strange about using the xrdb resource scrollWithBuffer: true mentioned in the urxvt man page. It doesn't seem to take effect. But when the setting is specified with -sw it performs correctly. – davidA Mar 21 '16 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.