I have this PC with an Asus P5N32-E SLI motherboard and an Intel Q6600 CPU. I got a new RX-5300 PSU, but it didn't work.

  • The motherboard power LED is on fine
  • When I switch power on, the PC powers up briefly (0.5-1 sec) then shuts down
  • From there on out when I switch power on, it stays on, all fans and components seem to be receiving power, but the motherboard won't POST. No video output, no PC speaker beeps, nothing
  • If I turn the hard switch on the PSU off and then back on again, go to step 2; The PC turns on and then off immediately again, and on subsequent power-ups it stays on but won't POST

I disconnected every component but the motherboard, CPU and PSU. Still nothing. I tried three other models of PSU on this PC, listed below, and they all work fine.

  • HEC-350AR-PTZ (350W)
  • SP-450P (450W)
  • NX-8060 (600W)

At this point I was convinced the PSU was faulty so I returned it. When the replacement arrived, it behaved exactly the same. So two different units of RX-5300 both with the same symptoms, neither working with this motherboard + CPU. Yet, three other models of PSU work perfectly fine. The PC store couldn't reproduce my problem with the returned PSU.

I tried resetting the CMOS with the jumper. I tried with both the 4 and 4+4 (with and without the extra +4 connected) CPU connectors (curiously the RX-5300 comes equipped with both cables fixed).

Could it be a statistical probability that I get two units of the same model of PSU that are faulty in the exact same manner? Could the RX-5300 model itself be somehow incompatible with this motherboard? I was under the impression that PSUs were pretty much universal so long as you have the wattage. Could the motherboard be broken in some such a way as to work with certain PSUs but not others? What's going on here?


Tested with a fourth PSU:

  • EA-500D (500W)

Now, it only POSTs with the SP-450P. The only difference I'm aware of with this PSU to the rest is that it's older as it has a fan connector. My current theory is that the motherboard is dying and the newer PSU refuse to work in those conditions. Maybe it's broken in such a way that it won't POST without a pwr_fan connector. At this point, I'm running out of resources to diagnose the problem and am considering if it's even worth the cost to send it to a professional - Rather than just acquiring a new mobo + CPU.

  • I have had motherboards that double POST when you pull power from them (e.g. unplug or flip the hard switch on the PSU). I understand it is common and involves a reset of {magic}. This doesn't explain your problem, but it sounds like one of the symptoms you describe. So the failure to POST after your initial start and reset is your problem, but the initial start-stop may be by design. – horatio Dec 30 '10 at 19:26
  • According to the NEXUS PSU spec and your Motherboard manual that PSU should work (using the 20+4 pin and the 2X4 pin connectors). +1 as I'd be interested to know what fixes this problem – Tog Dec 30 '10 at 19:28
  • 1
    Since PSU's have built in protection circuitry, Maybe that PSU is more sensitive to faulty hardware, maybe the problem is hardware attached to the motherboard or the motherboard itself. – Moab Dec 30 '10 at 19:43

For closure's sake, I gave up and rated the motherboard broken. The RX-5300 works fine on a new motherboard (the very same one I returned, in fact; I bought it back).


I guess your next step is to try a differnet brand PSU? check your mother manual to see if there are only certain PSU's that can be used with your MB. It seems strange but hey, anything's possible!

  • The manual simply recommends that the PSU comply with ATX 12 V Specification 2.0 (or later). Actually, it also recommends a minimum wattage of 550. Yet, it runs fine on an old 350-watt PSU. From nexustek.nl I see that the RX-5300 is ATX 2.2 compliant, so there's no rationale why it shouldn't work... But it doesn't. Two different units of the same model... – Core Xii Dec 30 '10 at 19:24

The way it supplies voltage could be different than your old PSU therefore it's not supplying the correct amount of voltage to a particular piece of equipment such as your motherboard. If that is true, it would just shut off due to not have enough voltage to power up your computer.

Another possibility is that you forgot a plug when plugging the PSU into the motherboard. The exact same thing happened when I built my first computer. I left a power cable unplugged, therefore is was lacking in power.

  • All cables are connected, I'm sure; I've tried this a couple times now. 24+4, 4/4+4 and the power cable to the PSU itself. CPU fan and PSU fan (with the HEC-350AR-PTZ) as well. – Core Xii Dec 30 '10 at 19:18
  • @CoreXii, this is a very weird issue... I was just thinking of anything possible. The only other possible thing is that the power to motherboard is different than the other PSUs you used and though it has enough Watts, it may not supply enough voltage specifically to your motherboard. – David Dec 30 '10 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.