When playing most movies in VLC player, the video feed is choppy while the sound is near perfect. Another catch is that this video issue wasn't always a problem. I used to play movies without problem with video or sound.

I cannot pinpoint what has changed between when it used to work fine and when it started being choppy.

I have an ASUS G73JW-A1. Movies that are normally affected are 4-9GB HD videos, but this system should be more than enough to handle the demand of playing HD videos. In addition, the videos are in MKV, MP4 (or M4V), and AVCHD (or M2TS) formats. I get the same results whether playing a movie directly from my hard drive or an external drive. Finally, all the drivers have been recently checked and updated if needed.

  • Did you run a memory check? Hardware acceleration? Do players like Flash (Youtube) and GOM work smoothly?
    – digitxp
    Dec 31 '10 at 1:55
  • I haven't perform a memory check yet. Hardware acceleration is enable in VLC. I can't really answer the YouTube question since I am in Afghanistan and HD videos takes too long to load. However, I do have other MP4 HD movies (in .mp4 instead of .m4v format) that play well in Media Player.
    – SgtOJ
    Dec 31 '10 at 2:03
  • Is it the latest version of VLC?, Uninstall, reboot and reinstall VLC
    – Moab
    Dec 31 '10 at 3:48

Go to Tools » Preferences » Input & Codecs.

Check Use GPU acceleration (experimental).

That just solved the very same issue for me in v.1.1.5 The Luggage.

  • 1
    I had it already enabled. I just disabled it..solved my problem
    – user398328
    Mar 24 '15 at 22:03
  • 1
    With VLC v2.2.2 you need to select the value VA-API video decoder via DRM for the field Hardware-accelerated decoding under the category Input & Codecs Settings.
    – Dor
    Sep 2 '16 at 10:42

Using VLC Media Player 3.0.6 (Vetinari), experiencing choppy playback from standard movie in DVD drive. Greatly improved after tweaking as follows:

1. Tools - Preferences - Input/Codecs - Hardware Accelerated Decoding: DISABLE

At bottom left, groupbox "Show Settings": ALL

2. INPUT CODECS (the menu itself, not a sub):
    - scroll waaaay down, to ADVANCED group
        - File Caching (ms): 5000
        - Disc Caching (ms): 5000

These settings should give you some areas to tweak.

Not the answer you're looking for? Browse other questions tagged or ask your own question.