I'm having difficulty printing from my Linux (Ubuntu 10.04) based PC to a printer connected to a Windows 7 machine. I was trying to connect using Samba (version 3.5.6) but this always brings up an authentication screen which never accepts any password I use.

So I read somewhere that an alternative is to access the Windows printer via LPR/LPD. I added an LPR/LPD printer in Windows 7, but even within Windows 7, I am not able to print as the print que monitor shows as 'printer busy'. The printer in question is an Epson Stylus DX7400 and works fine when using the standard USB ports....but doesn't when I use with the LPR/LPD ports. I even opened up the TCP/IP port 515 in my McAfee firewall without any success.

Any help with this would be highly appreciated.

Additionally, does anyone have any idea how I can get Samba working for me?


With Samba, it looks like I finally got this solved myself. I persisted with my searches in the internet and came across a Windows 7 forum which gave the following solution which worked:-

Open Network and Sharing Centre on the Win 7 PC. Click on change advanced sharing settings. Turn off password protected sharing.

I'd already turned on file/printer sharing, but because of password protected sharing being turned on, I was having difficulty in accessing the machine on my Ubuntu machine. Now that I turned this feature off, its working with Samba.


Still not sure about the LPR/LPD option, but now that Samba is working for me...I'll only really need to know about the LPR/LPD option out of curiosity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.