10

I opened up iTunes and the "Get" button is gone for downloading podcast episodes. This is strange because I haven't changed any configuration settings.

Economist Audio Edition:

alt text

BBC Global News podcast:

alt text

I tried unsubscribing and resubscribing to no avail. Does anyone know how this could happen?

1
  • Have you recently updated iTunes? Are you on Windows or Mac OS X? Can you try pressing alt/option while iTunes is launching, and temporarily create a new library, then subscribe to a podcast or two there? Does the issue disappear then? – Daniel Beck Jan 3 '11 at 11:30
7

I was wondering about the same thing earlier, just double-click the episode and it will be downloaded.

4
  • 1
    That must have been a Steve Jobs decree. Irritating. – craigmoliver Jan 3 '11 at 23:39
  • That sucks because you have to click everyone, not just "Get all" – craigmoliver Jan 3 '11 at 23:39
  • Hitting ENTER works as well. Much faster for long lists, just keep hitting DOWN and ENTER until you reach the end. – goldPseudo Aug 5 '11 at 17:16
  • Since when did press enter 50 times become faster than pressing "GET ALL".. Sorry Apple you fail! – Jafin Feb 13 '12 at 9:04
6

To fix it, go to control panel, then Add or Remove Programs (or Uninstall Programs). Then scroll down to find iTunes, right-click on it, and select repair.

2
  • Chopchopchops solution worked for me, too! Thanks very much! – user68770 Feb 23 '11 at 8:23
  • Worked for me too (iTunes 10.2.1) – JoelHess Mar 30 '11 at 1:39
1

There is no need to reinstall, or "fix" anything. The "get" button has been removed in favor of implementing podcast downloading by just double-clicking on the episode title.

Just double-click anywhere on the episode title and it will be downloaded as normal.

1

The "GET and GET ALL" are hidden. For me the buttons were hidden under the Date Released. clicking that will present the buttons.

0

Is this for all podcasts or just The Economist?

There is no podcast in the iTMS that goes by that exact name, though there is "The Economist: All audio." Maybe a podcast you used to subscribe to was discontinued on iTunes? A quick Google reveals that The Economist Audio Edition so described is a pay-for subscription podcast. Maybe that's a recent development, and why you can't get the episodes anymore.

Try searching for podcasts in iTunes by selecting the Store, entering your query, and then limiting your results to podcasts.

2
  • It's all podcasts. :-( – craigmoliver Jan 3 '11 at 2:34
  • I added another screenshot – craigmoliver Jan 3 '11 at 2:37
0

There is a topic about this issue on Apple's Discussion Forum

There currently isn't a resolution to the issue, but they did determine that the buttons are actually hidden and you can click them if you can find them.

I verified that this is the case - if you know where to click, you can click the invisible buttons. I'll stick with double clicking to download new podcasts until the issue if fixed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.