I recently bought Acer Aspire 5743z-4836 laptop and it worked fine until today.

Tried to reinstall the operating system. It just black screened with Acer logo after reinstallation and doesn't load anything further. When trying to load the BIOS with F2 it doesn't boot Bios.

How do I install or reset BIOS on my laptop?


Did you try any other keys? F10/F12 may actually be the BIOS keys. At what point are you actually pressing the F2 key?

  • 3
    I think this guy's problem is not to find how to enter to BIOS. I am sure he did try every combination of keys to enter into BIOS. His problem is that BIOS of his laptop is corrupted and he is searching for how to update it. – Bakhtiyor Jan 3 '11 at 15:45
  • 1
    Besides, it clearly says Press F2 to enter BIOS at the bottom-right. – Synetech May 25 '12 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.