I bought my lil sister's netbooks for Christmas and I've been having a heck of a time trying to get Internet Connection Sharing to work.

The host computer is a Windows XP box and it uses a US Cellular 3G modem dongle thingy to set it's Internet access. Additionally I have a hard wire plugged into the LAN1 port of the router described below. (I tried the WAN port out of desperation but things didn't seem happy that way.)

Additionally they have a linksys router (can't remember specific model number, I will find this out) that I was using to take advantage of it's wireless capabilities. Originally thought about updating the router to use dd-wrt, but after reading the instructions it looked like to much of a pita (had to downgrade firmware, then install dd-wrt) to set up, eventually I caved, out of desperation, and ended up successfully installing dd-wrt on the router. I have DHCP turned off on the router, actually all I could select was DHCP forwarder.

The netbooks both have windows 7 starter installed on them.

Initially, I had the networks joined to a homegroup but I dropped that and everyone is able to see everyone in their respective network explorers.

When I turn on Internet Connection Sharing on the host, its IP on the LAN changed to, so I arbitrarily decided to assign the router to port

When I connect the netbooks they get IPs dynamically.

As I stated before, everyone can see everyone in the network explorer, and shares can be accessed. The weird thing is that everyone can ping the router but they cannot ping each others IPs. The status on the netbooks says that there is no Internet Connectivity.

Another thing I tried was manually setting the DNS servers on the netbooks to the DNS servers that the host computer has. The funny thing is when I ping an outside domain such as google.com the IP address resolves, however I get no responses from the pings.

When I tried plugging the host into the WAN port I could ping the router, nor could I access the router's web access admin.

Another thing I tried was turning off the firewall on the netbooks and the firewall off on the host computer for the LAN connection, and they still could not ping each other. Also I thought I should be able to start a remote desktop connection but I couldn't do that either, I also checked to make sure that computers would in fact accept a request for remote desktop connections.

1 Answer 1


There were two issues here. Luckily I was able to consult with a friend of mine and we figured it out last night.

There were some settings which were not configured correctly on the Router. Once the Router was configured correctly the host was able to ping the client, but the client could not ping the host. I am waiting for my cohort to send me the link to the documentation he found on this because it was not where you would expect it. It was on the DD-WRT website, just in an odd place.

We also figured out that I could telnet from the host into the router using the username "root" and the admin password I had set for the router. The router could ping the clients but could not ping the host.

When I was about to give up, for some reason I thought about the anti-virus software. On the host, Avast Antivirus was installed, and unbeknown to me Avast has its own firewall, in the settings for the firewall there was a checkbox that was not checked to "Enable Internet Connection Sharing". I checked this box and we had joy!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .