17

How do you launch the Windows 7 "Picture Import Wizard"?

My Picture Import Wizard no longer autolaunches when I plug in my USB drive (although the drive is recognized).

How do I manually start the Import wizard?

Clarification Update: I don't have Windows Live installed and I'd prefer not to have to install anything new like Windows Live Photo, etc.)

10 Answers 10

9
+50

Maybe this is happening because autoplay has been disabled by default in Windows 7. This page shows you how to enable autoplay.

  1. Click Start and in the Search box, type gpedit.msc and press Enter.

  2. Now browse to Computer Configuration >> Administrative Templates >> Windows Components >> Autoplay Policies >> Turn off Autoplay.

  3. To Enable: Change the value of Turn off Autoplay to disabled.

  • 1
    Wierd. I had already gone in and set AutoPlay (from the Windows Control Panel interface) to RESET to defaults. Then also tried setting Pictures to "Import with Windows". No joy. But the method above (which I now remember is what I did last time) fixed it. – Clay Nichols Mar 21 '11 at 13:43
12

This works for me on Windows 7 Ultimate SP1 without any Windows Live apps installed.

  1. Right click on the USB device and choose "Open as Portable Device". A new icon for your camera will appear under Computer.

    Open as Portable Device

  2. Right click on the new icon and choose "Import Pictures and Video". Import pictures and videos

  3. You should now see the picture import wizard working: enter image description here

  • 2
    In step 2 I don't get the "Import..." option. – Clay Nichols Mar 21 '11 at 13:45
  • You can also right-click the Portable Device or Memory Card in Computer then select "Open AutoPlay..." – blissfool Apr 29 '13 at 21:16
5

win key + r (or: start -> run): "C:\Windows\System32\rundll32.exe" "C:\Program Files\Windows Photo Viewer\PhotoAcq.dll",PhotoAndVideoAcquire " your device should apear listed, if it's recognized.

  • Works on Windows 10 too... – Tomas Karban Nov 20 '16 at 19:06
  • Any way we can default it to a specific device? – Jim Buck Oct 31 '17 at 3:57
2

Click on Windows 7 Orb and type Windows Live Photo Gallery. After opening the program, click on Import (it's at the most left side of the ribbon) to open the wizard.

  • Thanks! This is actually the first idea that actually worked for me :) – Joel in Gö Dec 13 '13 at 23:24
2

Click on the Start menu button.

Type "autoplay" in the search bar

Press enter

If your iPhone is connected you should see at the bottom of the list.

  • Although your answer is correct, what makes you think the OP is trying to connect an iPhone? – HaydnWVN Dec 13 '12 at 14:48
1

The above answers are great and solve the question; however, if you can't install the Live Photo Gallery tool for whatever reason (such as being in a win32-compatible environment that is NOT Windows), there is the PhotoImport tool (see https://code.google.com/p/photoimport/) that one can always use and install as well (Mono and Gtk# for Mono required), which seems to also run on gnu/Linux systems as well.

Edit: If you're in a win32-like environment, install the Mono Framework 2 or higher (or the .net framework on Windows). Install Gtk# for Mono. Open Photo Import once you've unzipped the folder. Click Settings and find your device. Click Import. Your photos should begin importing.

0

If you have Windows Live Photo Gallery installed you can run the program C:\Program Files (x86)\Windows Live\Photo Gallery\WLXPhotoAcquireWizard.exe

0

Win explorer crashed on right-click, so 'open as portable device' not possible. Nor do I have or want Windows Live Photo Gallery. Autoplay was enabled already in control panel Nor do I want to download any new tool. It shouldn't be that damned hard!

  1. Right-click the USB drive icon in the task bar.
  2. Choose 'open devices and printers'
  3. right-click the desired device (mass storage device) in the dialogue
  4. choose 'auto-play' -> 'removable disk [your disk letter]'
  5. choose 'import'
  • Welcome to Super User! This is not an answer to the original question. If you have a new question please ask your own question (referencing this one for context if it helps). – DavidPostill May 31 '16 at 11:15
0

I don't much care for the Wizard. Why? Because (1) It lets you import once and then says "0 new pictures found". So if you mess up the folder on your PC, you'll struggle to re-import. (2) It imports ALL pics, chat emojis, etc it can find from all sorts of apps, which is usually not what I want (3) the "Review, organise and group..." option is tedious when importing a lot of files from different dates. (4) the "Import all new items now" gives poor results with the default Options

Results are greatly improved if you click on "More Options" before you decide to "Review, organise and group..." or "Import all new items now". Personally, I change Foldername to "Name" and Filename to "Original File Name (preserve Folders)". And I ensure that "Delete files from device..." and "Rotate Pictures..." are both unticked.

But usually, I just access the Phone like an external disc drive and copy the files I want.

What follows describes photo import WITHOUT use of the Wizard. This works using WINDOWS 10, talking to a Samsung Android phone attached via USB and unlocked (ie.it's ready to use). It may work with other s/w and h/w but YMMV as they say.

Find the phone under "This PC" (Computer). Double-click it and it appears like another drive. Then double-click the "Phone" drive. Your Photos will be in Folder DCIM\Camera. Select what you want and drag or copy to a folder on your PC, as normal. Other APPs' pictures will be in their relevant folders, e.g. WhatsApp\Media\WhatsApp images\ , or Pictures\Facebook\ ... etc. You can even search the phone for, say ".jpg" using Explorer's "Search" field in the top right of the window.

-1

I had to go in and remove the apple mobile driver in programs and features under the control panel. When I reconnected my phone it reinstalled the correct drivers.

  • This is an answer to some other question, not this one, which has nothing to do with apple phones. – DavidPostill Jan 28 '17 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.