73

I'd like to provide a guest OS with multiple CPUs in VirtualBox. My host machine is a quad core HP Compaq and uses the Intel Core 2 vPro hardware.

However, when I try to enable the setting in vbox, I get an error that VT-x is not available. Is this something that I can enable somewhere? how do I find out otherwise whether my hardware supports it?

edit: per suggestions below, I tried using the Securable tool, and it reports that hardware virtualization is "Locked Off". The processors are reported as "Intel Core 2 Quad CPU / Q9400 @ 2.66GHz"

  • 1
    Make sure your hardware support vt-x check list, then make sure it is enabled in BIOS. – Joakim Elofsson Aug 14 '09 at 19:04
  • Were you able to find the setting in the BIOS? If not, give us the model name/number of your HP. – arathorn Aug 14 '09 at 20:36
  • Turns out I just wasn't looking in the right place in the BIOS. It was under the Security menu :-) – Joel Martinez Aug 14 '09 at 20:38
  • 1
    Sometimes it may be on the OS level (Windows) - in the "Windows features" I had to turn Hyper-V to OFF (required restart). Then VirtualBox started using it. – Tomasz Gandor Nov 21 '16 at 11:35
45

You can use the tool Securable from Gibson Research to find out if your hardware supports virtualization extensions. If it tells you that your hardware is supported, but not enabled, check the BIOS settings to enable it.

  • I used securable and updated the question text with what it reported (Locked Off). I poked around in the BIOS but could not see anything about VT-x, hardware virtualization, or vmx – Joel Martinez Aug 14 '09 at 19:46
  • "Locked Off" means that your processor supports virtualization, but that it has been disabled in the BIOS – heavyd Aug 14 '09 at 19:56
  • 1
    On my Dell Optiplex 960, the only way to get VT enabled is if the other virtualization options (direct IO and trusted execution) were explicitly disabled. – Nic Apr 3 '13 at 17:01
  • 1
    Bitlocker users beware: changing your VT settings may force you to enter your Bitlocker recovery key. If you didn't save your recovery key, turn off Bitlocker before changing settings. – Nic Apr 3 '13 at 17:01
  • 1
    @vijay, the BIOS settings are specific to your computer manufacturer, however most of them require you to reboot the computer. Usually, you can hit F2 or F12 or DELduring the POST to enter the BIOS setup. – heavyd Mar 19 '15 at 14:08
26

Start your PC, press F2, go to the security option and enable VT technology.

  • 12
    In some new BIOS, it called Virtual technology or Intel virtualization in the CPU setting option. – Java Xu Jul 9 '13 at 2:13
  • Is there any possible to enable BIOS virtualization setting without restart system.Or possible to change inside the system .My system while restarting F2 button is not working i need to enable BIOS virtualization.Is there any possible? – vijay Mar 19 '15 at 7:48
  • I have VT-x technology (check on internet and several programs) i53120M on my laptop, but there is no that option in BIOS. Virtual box says I can't use virtualization accelleration and proccesors section is grayed out. – Vlado Pandžić Aug 29 '15 at 23:39
7

Your processor does support VT-X, you'll just need to enable it in the BIOS settings. Reboot your computer and press the specified key on the boot screen to go into the BIOS Setup and enable it.

  • added specifics about the CPUs on the host. let me know if there's something else I should give you specifics on. thanks! – Joel Martinez Aug 14 '09 at 19:45
  • Is there any way to enable vt-x without using the BIOS? I just bought a laptop with an Intel 3820QM and the bios does not give me this option; other people complain about it also so it is not something I missed. It is a Clevo P170EM – Ritsaert Hornstra Jun 5 '12 at 21:09
  • 1
    I do have an Ivy Bridge Laptop and it should support VT-x but... The BIOS has no option to enable it; is there another way to enable it? I might create a new SuperUser question. – Ritsaert Hornstra Jun 23 '12 at 11:42
  • After some searching I found a newer (looks like unofficial) BIOS with the support for VT-x always on (instead of always off). – Ritsaert Hornstra Jun 24 '12 at 18:07
5

This may not be obvious. Its sometimes called vanderpool technology in the bios without mentioning virtualisation.

5

As a side note: some laptops require you to shut down and power off the laptop after enabling VT-x in the BIOS, and removing the power cable and battery for 30 seconds. I just today had such a laptop, and found this solution here.

3

Reducing RAM in VirtualBox from 4gb to 2gb worked for us when we had only RDP to host machine so couldn't access BIOS.

2

For me, "VT-x is not available" was highly misleading - I had my computer upgraded to Windows 10, which had turned on Hyper-V, which lead to the error message.

Disabling Hyper-V from Windows Features solved the issue. Based on comments here I'm not the only one.

Note that for example Docker in Windows 10 wants Hyper-V enabled. This means that you cannot run Virtualbox and Docker on the same Windows machine, thing Docker warns you about:

(outside Windows 10/Docker, Docker Toolbox is used to run Docker in Windows, which works with VirtualBox just fine)

0

On My Sony Laptop, the setting is Intel(R) Virtualization Technology, which is under Advanced tab.

-1

We are 2020-jan. I met this issue again !

It is thanks to Windows 10 Pro's Sandbox new feauture, which has been deployed with the latest Win10 Update. When enabled, this feature will implicitly use VT, and this, in a selfish and exclusive way. So afterward Virtualbox will fail at starting any common combination Guests (Ubuntu 64, MX 64). Even the guests that were working don't start and throw the error :

Failed to open the guest

VMMR0_DO_NEM_INIT_VM failed : VERR_NEM_MISSING_KERNEL_API (VERR_NEM_MISSING_KERNEL_API).

VT-x is not available (VERR_VMX_NO_VMX).

E_FAIL (0x80004005) Component : ConsoleWrap Interface : IConsole {hexacode}

Indeed, BIOS has them enabled, that wasn't the change. There were previously running guests. And Securable tool was able to diagnose and follow up the state of the PC even after solution. Normal state and after solution : 64/Yes/Yes. When VBx Guests did not start, Securable gave 64/Yes/No.

So I had to : - go into Turn Windows Features On or Off - Disable Hyper-V - Disable Windows Sandbox - any change to this implies a Windows restart. The light way of Windows restart did not work right away for me. I recommend a PC stop/pause 10sec/start (not rational, just this way it works for me). Be perseverant.

  • Not needed to go to BIOS : because already Enabled Virtualisation options, and all worked previously

Not the answer you're looking for? Browse other questions tagged or ask your own question.