I have a brand new Transcend StoreJet 25M3 (external HDD) mounted to MacBook (Leopard 10.5.8) at /Volumes/Transcend. I copied some data from my old Windows (XP) machine on it, and now, after cleaning some stuff up, I wanted to delete some directories, but this is what happened:

$ rmdir My\ Pictures/
rmdir: My Pictures/: Operation not permitted

Using Finder just asks for password, but does not delete the directory (sound of "moved to Trash" is played).

I thought it's some permission "thing", but:

$ ls -l
drwxrwxrwx  1 martin  staff   32768  5 jan 16:11 My Pictures/

$ sudo rm -rf My\ Pictures
rm: My Pictures: Operation not permitted

I re-mounted, rebooted (thinking that there's some file lock), but that did not help.

What might have happened here? How to delete it?

  • You copied from your XP machine? What partition format is it? HFS+, FAT? – Daniel Beck Jan 5 '11 at 16:03
  • @Daniel, Win is NTFS, drive is FAT32. – Martin Tóth Jan 5 '11 at 16:06
  • Can you delete any other directory? Can you perform other actions, such as creating files? Can you move the files from this folder to another folder? You could, of course, try to delete from a Windows machine. – Daniel Beck Jan 5 '11 at 16:11
  • @Daniel, every other file system operation I tried works: creating/moving files/directories, I can even create content in that directory. – Martin Tóth Jan 5 '11 at 16:18
  • 1
    Probably the readonly attribute is set. I'm not sure if there is a way to change that flag on a directory from the Mac. – mark4o Jan 5 '11 at 18:08

I suggest running a disk checker, don't know what you would use in Mac, maybe fsck?

Are you able to rename/move the file?

Last resort, format the partition.

  • Rename (mv) gives same error. I'll look into FS/disk checking. – Martin Tóth Jan 5 '11 at 16:04
  • 1
    Have you tried deleting it from a different operating system? – bryan Jan 5 '11 at 16:06
  • I tried verifying it with "Disk Utility": ** Phase 2 - Checking Directories: '..' entry in /Music has non-zero start cluster, which is weird, and not related to My Pictures (which is in /SORT/..../My Pictures) – Martin Tóth Jan 5 '11 at 16:24
  • Disk Utility's repair fixed the non-zero start cluster issue, but still can't delete it. As I've commented above, I'm going to try it from other OS (later, I do not have available right now) and let you know. – Martin Tóth Jan 5 '11 at 16:32

I have had this issue many times. OS X cannot by default write to an NTFS formatted drive (which is probably how the drive is formatted since you started using it with the XP). You need to install special drivers for the Mac OS X to be able to write to the NTFS file system. This link will help you understand this more thoroughly.

-Hope this help!

  • Drive is FAT32 as per his comment. – Daniel Beck Jan 5 '11 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.