I am using an external monitor for my laptop to run Ubuntu with. I just updated Ubuntu today, but when it is about to reach the Ubuntu login screen, then the monitor says "out of range." Now, Ubuntu boots up into the GUI if I unplug my monitor and use my laptop screen, but I prefer to use the external display. I have tried all of the suggestions from my search results in Google.

I tried pressing Ctrl + Alt + +, but nothing happens. I tried pressing Ctrl + Alt + -, but nothing happens.

I used Ctrl + Alt + F2 to get into a terminal to run the command:

sudo dpkg-reconfigure xserver-xorg

but nothing happens. I believe there are supposed to be options to change the settings, but it does not even give me any.

I tried to edit /etc/usplash.conf and /nano/etc/usplash.conf, but they do not exist.

I did sudo apt-get update and sudo apt-get upgrade hoping that it would install drivers or something to help my situation, but they did not help.

My monitor is a Westinghouse 22" LCD with resolution 1680x1050. It has been working for the past few months until I updated it today.

  • dpkg-reconfigure xserver-xorg hasn't given resolution options since 2007 or 2008 – maco May 10 '11 at 19:24
  • Does your laptop screen stay on this whole time? If so, you should be able to set a different resolution for the external monitor either with the Display settings or using xrandr – maco May 10 '11 at 19:25

First find out what you updated. System -> Administration -> Synaptic > File > History. Look for anything which sounds related to a graphics issue or driver update. See if you can rollback to an earlier version of the suspect program.

Were you using an external driver for your graphics card? Some Nvidia cards ask to install a third party program which is much better at handling some setups. Maybe your custom driver (if you have one) got clobbered.

The only other thing I can think of is an issue with the monitor. Try resetting it to factory settings, or try a different monitor to see if that does the trick.

  • Hello, when I open up the history, there are no entries. It's totally blank. – Kelp Jan 7 '11 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.