I'm having some unusual and sporadic hard disk clicking issues. Here is a cronological description of the facts.

I'm using an ASUS P6T-SE with Intel Core i7, 6Gb RAM 600W Power supply and ATI4670 graphics, running Ubuntu 10.10.

About one month ago my hard disk (SATA II Seagate Barracuda 1Tb 7200 rpm) started making a clicking sound: a sort of loud tic-tac, every second or so, when involved in disk activity. The system was clearly slower than before at disk access, but it was functional and I could not find any signal of trouble on the linux logs. I disconnected the disk and tried an older SATA drive I had around: no problem with it. Then I reconnected the Seagate disk, and the problem was mysteriously gone. Ubuntu booted normally, usual speed, no clicking.

A couple of weeks later, the problem reappeared. I tried disconnecting reconnecting (as it somehow solved the problem before) without luck. So, despite it was a rather new drive, I assumed it was a hardware issue, made backups and bought a new drive.

The new drive is a SATA II Seagate Barracuda 1.5 Tb 7200 rpm. I installed both drives at the same time, with the intention of transferring my files from on to the other. To my surprise, when I booted the computer with both drives, both started making the clicking sound !! Even worse, I removed the old drive, leaving the unformated new drive connected, and booted from a LiveCD. It kept clicking !

Puzzled by this, I tried both drives on my laptop with a SATA to USB cable. At the moment I connected any of them, they made one or two unusual clicks and immediately stopped doing that and worked normally. The old drive I thought almost dead, was working like a charm as if nothing happened.

Then I thought: "ok, it must be the motherboard. Let's try again". So, I reconnected the old drive to the ASUS P6T motherboard (the same cables and SATA port as before), and it worked as if nothing happened ! The problem was gone again. The new 1.5 Tb drive was also working ok: No clicking nor slowdown.

So I left the old 1Tb disk connected and kept using the computer daily during 3 weeks, until today it happened again. Now I don't really know what to do or check. I'm not even sure if it is a hardware issue any more !

This is rather annoying as it seems it happens with a period of 2 or 3 weeks and I have no means of forcing it to happen. Does anyone have a clue of what can causes this behaviour or have any suggestions of things I should check when it happens again ?

What I did today is checking some SMART parameters

  • Error log: smartctl -l error /dev/sda. No errors
  • Short selftest: smartctl -t short /dev/sda. No errors
  • Disk Health check: smartctl -H /dev/sda. passed

And here are the vendor specific parameters (smartctl -A /dev/sda) Which I'm not quite sure how to interpret.

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     0x000f   120   099   006    Pre-fail  Always       -       235962588
  3 Spin_Up_Time            0x0003   095   095   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   100   100   020    Old_age   Always       -       187
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   072   060   030    Pre-fail  Always       -       16348045
  9 Power_On_Hours          0x0032   096   096   000    Old_age   Always       -       3590
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   020    Old_age   Always       -       94
183 Runtime_Bad_Block       0x0032   100   100   000    Old_age   Always       -   
  • Why does your drive not report parameter 193? Jan 6, 2011 at 15:46
  • No idea. What does this parameter tell ? Jan 6, 2011 at 16:02
  • I think 193 is load cycles - how many times the heads have been loaded. If it's abnormally high the heads might be wearing out.
    – Shinrai
    Jan 6, 2011 at 18:14

1 Answer 1


Have you tried setting the Advanced Power Management to OFF?

hdparm -B 255 /dev/sda 

You can check your current setting with:

hdparm -B /dev/sda

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .