I have a Windows 2003 R2 Enterprise Edition SP2 32-bit machine with all latest patch (as of 1-6-2011). It's a VM.

I have a zip file, including a pdf file, a txt file and a exe file.

If I copy the zip file onto the machine via a shared network drive, I can unzip all the files properly without problems.

If I put the zip file on my web server and then I download it from there, I can only unzip the pdf file and txt file. The exe file is silently ignored.

I searched the web and found somebody reporting similar issue on XP.

If I right click on the zip file downloaded from the web server, at the bottom of the general page, it has a warning message saying that "This file came from antoher computer and might be blocked to help protect this computer"

I understand that I can solve the problem by simply clicking the "Unblock" button and extract the file again.

The things that bothering me is that why the warning message says "might be blocked"? I tried downloading the same zip file from the same web server on to my Windows 7 box with latest patch. It also shows the same warning message. However, even with the warning message, I can extract all the files properly without clicking the "Unblock" button.

Is it a bug in Windows 2003 R2 SP1? Is there any security settings controlling this? How likely will the end user seeing this problem? I want to dig into this because I am worrying people downloading my zip file from my web server might see similar problems. The first thought coming to the user's mind will be the zip file is somehow corrupted. Honestly, I didn't know this "Unblock" feature in Windows before I run into this problem.


I just tried it on another Windows 2003 R2 SP1 machine. The zip program doesn't block the EXE file on that machine either. Both Windows 2003 R2 SP1 machines are joining to the same forest.


I updated the other box to have latest security patch. I don't see the problem either.

As what Jeff suggested, I uninstall the Internet Explorer Enhanced Security Configuration. It's working fine. Then, I add back the Internet Explorer Enhanced Security Configuration again. The weird thing happens. Now, it's working fine even with Internet Explorer Enhnaced Security Configuration on. It's just the same as all other boxes now.

  • Are you using any software to extract the files, or just the built-in Explorer CAB/ZIP handler? – Breakthrough Jan 6 '11 at 20:08
  • I am just using the built-in explorer zip handler. – Harvey Kwok Jan 6 '11 at 20:31
  • Have you tried any of the (free, open-source) alternatives, like 7zip? 7-zip.org – Breakthrough Jan 6 '11 at 20:37
  • @Breakthrough Sorry, I cannot try your suggestion since the problem is gone now after removing the IE Enhanced Security Configuration and adding it back. I would appreprciate if anybody has any thoughts on what's going on – Harvey Kwok Jan 6 '11 at 20:52

Do you have Internet Explorer's Enhanced protection configuration enabled? I find that super annoying and will often block EXEs from running. You can check this in add remove programs under Windows Components.

| improve this answer | |
  • Thanks, I think I get one step closer. Removing the Internet Explorer's Enhanced protection configuration from Add/Remove program does fix the problem. However, I have another 2003 R2 SP1 on the same network. It also has the Enhanced protection configuration enabled. I don't have any problem on that machine. However, it doesn't have the latest security patch though. I will try to update that machine to have the latest security patch and see. Thanks for the reply. – Harvey Kwok Jan 6 '11 at 20:31
  • Glad I could help :) Just remember to accept if it worked for you! – Jeff F. Jan 6 '11 at 20:33
  • Update the post with my latest findings. It's still weird to me although the machine is now working fine. I will leave it open for couple days and see if anybody have any ideas on what's going on. No worry - I will pick the one that helping me most as an answer ;) – Harvey Kwok Jan 6 '11 at 20:50

This is fairly normal behaviour and is typically expected by users. I'm surprised that you've never run across it. I have it happen all the time on Vista and 7. I'd recommend putting a note on your download page that instructs users on what to do if they're unfamiliar.

| improve this answer | |
  • That's what I am planning to do. Are you sure it happens on all latest Windows machines? I don't see it on my Windows 7. This is really the first time I see this problem. – Harvey Kwok Jan 6 '11 at 20:33
  • I can only say that it happens on my Windows 7 machine generally speaking for downloaded EXEs and that I've used other machines that do it too. I find it unlikely that my plain vanilla install is special somehow, but I suppose it's possible. – Brian Knoblauch Jan 6 '11 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.