0

When I try to run Firefox 3.6 or 4 beta I get a message saying:

Profile Missing
Your Firefox profile cannot be loaded.  It may be missing or inaccessible.

I have tried running the profile manger from the command line using:

/Applications/Firefox.app/Contents/MacOS/firefox-bin -ProfileManager

I get the same message in the popup, but I also get:

Error: Access was denied while trying to open files in your profile directory.

I have tried deleting Firefox and reinstalling it. I have also tried deleting anything related to Firefox or Mozilla in the ~/Library/Application Support directories, but nothing seems to help. In addition I have run the disk utility to fix any permissions issues.

If I create a new profile or run the command with sudo, it works. It seems that that Firefox is trying to put the profile somewhere it doesn’t have access to write, but I can’t figure out how to change this location or change the permissions. Any help would be greatly appreciated.

1
  • Is your account allowed to make administrative changes on the machine? Did you install Firefox as the same user as you're now trying to run it under?
    – Harv
    Jan 7 '11 at 3:56
1

A command was posted on the Firefox Help forum which works well to solve this problem:

Run this command in terminal from your home directory:

sudo chown -R `id -un`:`id -gn` ~

Give it a try. Your Mac will ask for your admin password which scared me a little. Firefox 4 works fine now on my MacBook Pro with OS X 10.6.7.

1

Cheng's response is a command that changes everything in your home directory to be owned by you. On my machine I only needed to do:

    sudo chown -R `id -un`:`id -gn` ~/Library/Caches

chown means 'change owner' and the '-R' means recursive

id is a command that returns your username with '-un' and your group name with '-gn'.

0

A low-rep user (Max2002) offered this suggestion:

I had a user that had Firefox 41.0 getting the error.  It turns out that the Caches folder within Library was not there.  There was a shortcut with the same name in its place.  I deleted the shortcut and Shazam! problem solved.  Running Firefox created the proper folder and the user could open Firefox!

Not the answer you're looking for? Browse other questions tagged or ask your own question.