0

I'm on Fedora 14, and OpenOffice 3.3.0 takes a long time to open (about 30 seconds, sometimes less). It isn't a CPU or disk performance issue, it's just simply a very long delay before the program opens. It appears to be a frivolous network connection timing out.

According to Wireshark, it tries to look up:

dulcimer.(none)

which fails, after which it tries to look up:

dulcimer.(none).mylitestream.com

(dulcimer is my hostname, and LiteStream is my ISP)

Is there a way to work around this bug in OpenOffice?

2

Add that address to your hosts file make it point to 127.0.0.1 and also, disable java from the settings menu, it adds to the opening time.

| improve this answer | |
  • 1
    P.S.: I want to accept this answer because it's simpler and easier than mine, but your answer wouldn't be easy to understand for someone who doesn't know what "your hosts file" is. Could you clarify? Thanks. – Joey Adams Jan 8 '11 at 1:54
2

I fixed it by changing my hostname from dulcimer to dulcimer.none, as suggested on another webpage.


How to change your hostname on Ubuntu:


Edit /etc/hostname, and change it from:

yourhostname

to:

yourhostname.none

You also need to edit /etc/hosts, changing any occurrences of yourhostname to yourhostname.none .

Then, reboot. Actually, you can get away with not rebooting by typing:

sudo hostname -F /etc/hostname


How to change your hostname on Fedora:


Edit /etc/sysconfig/network, and change the HOSTNAME setting:

NETWORKING=yes
HOSTNAME=yourhostname

to:

NETWORKING=yes
HOSTNAME=yourhostname.none

You don't have to edit /etc/hosts like you do on Ubuntu, as it is updated automagically.

Then, reboot. Actually, I think you can get away with not rebooting by typing:

su -c 'hostname yourhostname.none'
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.