I run openSUSE 10.2 VM on VMware on a Windows Vista host. Yesterday I run VMware and another VM but both couldn't run, and I ended both tasks to solve it. But now I can open VMware without any problem and run the other OS VM but not the openSUSE VM. The error is:

Cannot open the disk 'C:\Users\hamide\Documents\Virtual Machines\SUSE Linux 2\SUSE Linux 2-000003.vmdk' or one of the snapshot disks it depends on. Reason: Failed to lock the file.

I don't have any backups.

  • Check out sharethelearning.blogspot.com/2008/02/… It is a little old but I am sure if you google that error you will find something more up to date.
    – Jesse
    Commented Jan 8, 2011 at 3:40
  • Ask this on superuser.com .
    – houbysoft
    Commented Jan 8, 2011 at 3:55
  • Can you just copy the vmdk and re-attach the copy to your instance?
    – Lenik
    Commented Jan 10, 2011 at 4:00

1 Answer 1


The answer is to remove or rename the .lck file (as posted in the link in the comment to the question, answered here for posterity). Search for vmware KB "Investigating hosted virtual machine lock files".

You must log in to answer this question.