I opened up Spotlight, typed '12*' to do some multiplication and it's been frozen for the last 20 minutes.

I am looking for how to restart the program/service/whatever it technically is, but it's not in the Force Quit menu, so what is the quickest way to kill this process without restarting my computer? (I am on Mac OS X Snow Leopard)

  • Damon, why you accepted an answer that didn't work for you? I for one just got the exact same issue for the first time, tried the exact same measures, including from your comments below, and then tried every suggestion in the answers but still got nothing. It's still frozen there. Did you ever solve this without a reboot? :P – cregox Apr 12 '11 at 1:16
  • so you tried all that terminal junk and no dice? – Damon Apr 12 '11 at 1:42
  • the terminal junk is the same as the activity monitor junk, just like Wilersh said himself. and yep, no dices there. Spotlight is now behaving weird and I do think it triggered the issue but now I know it is actually the task/notification bar that's locked. My clock has stopped and the colorful hourglass is all over every regular mac icon there. – cregox Apr 12 '11 at 1:46

Depending on your OS and luck, it could actually be 1 of at least a few [services]:

  • mds
  • SystemUIServer
  • Spotlight

To me, a while back when they were called feline names, I've had the same issue (as I was saying on the comments) and it was not Spotlight: it was the Menubar. Just like with spotlight, we simply have to kill it so it will be restarted by launchd.

For that, use the Activity Monitor and search for your [service].

Or you may instead use the Terminal, for instance:

killall Spotlight

And if that doesn't work, consider using sudo.

  • 2
    I seem to recall the clock stopped changing for me as well.. though can't be certain.. it was 3 months ago after all hehe – Damon Apr 12 '11 at 2:37
  • 1
    I had the same problem, and ended up restarting.. The entire notification area was frozen, so the answer may have been to restart/kill that process. – mpe May 18 '11 at 8:17
  • 1
    I tried this solution and it worked (I did it from the Activity Monitor, but that's close enough) – iwein Jul 19 '11 at 11:17
  • 2
    @Damon - I can confirm that the clock stopped changing for me. – lindon fox Aug 17 '11 at 6:33
  • 1
    This doesn't work in Mac OS Sierra. See answer by tomng below. – guidod Mar 16 '17 at 13:32

Just ran into Spotlight itself crashing. The answer for that problem is just going to the Terminal and typing:

killall Spotlight

Fixed the Spotlight freeze problem!

  • 1
    This worked for me. killall systemui didn't work – Goldname Oct 30 '16 at 1:36
  • 1
    Also worked for me while the approved answer didn't. My symptom was not being able to type into spotlight (launched fine, just did nothing when launched) – Ryan Dec 23 '16 at 7:05
  • 1
    Worked for me on macOS Sierra. I believe the accepted answer is from a time when Spotlight was in the menu bar. – Nick Jan 13 '17 at 14:35
  • Spotlight would open but not accept any input, this fixed it for me on macOS Sierra. – Drew Goodwin Feb 1 '17 at 19:09

It'll probably show up in /Applications/Utilities/Activity Monitor.app. Select All Processes in the toolbar to see processes of all users.

The screenshot is from when I was searching something. I guess you'd kill mds by pressing Cmd-Opt-Q after selecting it to terminate Spotlight, but I'm not sure -- probably best if you checked CPU usage and/or if the name of a process is written in red, indicating it froze.

alt text

  • odd.. as soon as I force-quite it, it appears back there and my spotlight menu is still up working away at nothing. – Damon Jan 10 '11 at 22:22
  • 1
    @Damon It's a server intended to run all the time, and gets restarted once you stop it. If it were responsible for the issue, killing it would fix it. Have you tried looking for another task, that maybe uses much CPU, or maybe tried to simply restart Finder? – Daniel Beck Jan 10 '11 at 22:24
  • restarting finder was the first thing i did.. nothing else really doing much other than Window Server.. looks like i'm just going to have to reboot – Damon Jan 10 '11 at 22:54

The first post is correct that mds is the process for spotlight. You can kill it in activity monitor or:

sudo killall mds

from the terminal. The process will restart automatically as it is managed as a launchd item that is set to always be running.

You might look at

man mdutil

as well. This is a utility at the command line for managing mds settings on volumes.

  • Killing mds does not work for me either. – Jonny Jun 6 '14 at 4:05
  • It goes away and the process returns, but the spotlight icon is gone, and the keyboard shortcut doesn't work. – Jens Timmerman Jan 16 '15 at 8:49

I'm not sure why this wasn't mentioned on here, but I had a locked up Spotlight menu/search box was able to solve the problem by killing the Spotlight process using the Activity monitor. None of the other actions mentioned in other answers worked.

This was on OS X El Capitan.

  • 1
    alternatively ps -e | grep "Spotlight" then kill {process id for spotlight} – Aristides May 9 '16 at 0:06
  • 5
    killall Spotlight did the the trick for me (on OS X El Capitan). – Josh Foskett May 15 '16 at 16:33
  • look at the dates. El Captain wasn't even in the planning board back then. – cregox Mar 16 '17 at 18:04

For the record, just had this issue but I couldn't get terminal or activity monitor to work. The solution? Use Apple+Option+esc to bring up the Force Quit Applications dialog, select the trouble app, then click the "force quit" button.


  • 1
    Apple + Option + Esc is also a great advice... I hope I recall that the next time spotlight seem to freeze. Which trouble app did you happen to kill in your case? – cregox Nov 13 '13 at 19:58

In Activity Monitor I stopped "Quick Look UI Helper." This might be a bit less brute force than some of the other suggestions, assuming that's what is hanging up in your case, too.


06-19-14 I had a Spotlight-created, seemingly frozen dialog box describing an Evernote note with 0KB. I logged off, then logged back in. The dialog box disappeared. Did not need to reboot. Spotlight itself continued to function normally even though the previous "hit" was still stuck on the Desktop screen.


In Yosemite: kill mds_stores and mds. They'll restart automatically and then Spotlight works again. At least, that's my experience.

  • 2
    This also restored my ability to use Spotlight to start applications on 10.9, and search in Mail works again, too. Thanks! – Bombe Feb 26 '16 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.