I tried building node.js on Cygwin and that caused errors, so someone in #node.js on freenode told me to run rebaseall on Cygwin to clean it up. So I tried that and I got the following message:

$ rebaseall

rebaseall: only ash or dash processes are allowed during rebasing

Exit all Cygwin processes and stop all Cygwin services.

Execute ash (or dash) from Start/Run... or a cmd or command window.

Execute '/bin/rebaseall' from ash (or dash).

So I closed Cygwin, went to Start/Run and tried ash and dash but got the following alert:

Windows cannot find 'ash'. Make sure you typed the name correctly, and then try again. To search for a file, click the Start button, and then click Search.

So what am I supposed to do?


Try invoking ash by giving its full pathname. For example, if you installed Cygwin into C:\cygwin\, then you would type this into the Start/Run dialog box:


This should start the ash shell, within which you can then invoke /bin/rebaseall.

| improve this answer | |
  • 11
    If rebaseall still complains, check task manager for zombie Cygwin processes like sh, bash, ssh, etc. – spoulson Apr 27 '11 at 13:37
  • @spoulson - I had ssh-pageant still running. I had to kill it via Task Manager. Thanks! – sancho.s ReinstateMonicaCellio Apr 15 '19 at 1:36

If you are running Cygwin-X make sure the X is closed, not just the xterms.

| improve this answer | |

Expanding on this comment, using Win 10 and Msys2 from PortableApps, I went to Task Manager.

Given the large number of running processes, I sorted the list by the column "Command line". There I found my ssh-agent from Msys2 still running. I killed it, and then I could rebaseall .

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.