121

I want to change my shell from the default bash shell to zsh on my Amazon EC2 instances. How do I go about doing it? Thanks!

159

Try using the chsh command.

e.g.

chsh -s /bin/zsh

You can confirm the location of zsh by running whereis zsh, or alternatively simply run

chsh -s $(which zsh)

If you want to change the shell for a user account other than the one you're logged into, you'll need to run it as root, so to change john's shell, do:

sudo chsh -s $(which zsh) john

Note that you'll need to log out and log back in for the change to go into effect. If you're using Gnome or some other window manager, you'll need to completely log out of that session as well—simply closing and opening your terminal is insufficient.

  • I did try that, but with the root user!! My AMI Image has ubuntu rather than root. Had to switch to ubuntu user to change the shell! Thanks for the hint :) – Shripad Krishna Jan 11 '11 at 11:45
  • 3
    @Paddy if you are root you can change it for another user by running chsh -s /bin/zsh username. – John T Jan 11 '11 at 11:47
  • Awesome :) Much easier. Thanks for that info too. – Shripad Krishna Jan 11 '11 at 11:48
  • 3
    @We are the World: You need to add /usr/local/bin/zsh as a new line to /etc/shells – Nate Parsons Jun 4 '13 at 17:54
  • 5
    I use a lightly different version sudo chsh -s $(which zsh) $(whoami) – SergioAraujo Apr 30 '15 at 19:37
20

Open /etc/passwd:

sudo vi /etc/passwd

Find the line with your username:

username:x:1634231:100:Your Name:/home/username:/bin/bash

and replace bash with zsh:

username:x:1634231:100:Your Name:/home/username:/bin/zsh

Log out and log in back for the changes to take effect.

  • 6
    It's better to use chsh, but if you're really going to edit /etc/passwd by hand, at least use the vipw command. – Valmiky Arquissandas Aug 14 '14 at 2:58
  • I don't have chsh on my machine. Also, for some weird reason my /etc/passwd file is regularly being overwritten by the default one. Do you know why this could be happening? – Georgii Oleinikov Aug 14 '14 at 16:44
  • Don't touch /etc/passwd. There are better ways to do this that do not require messing with the passwd tool! – Andrew Sep 12 '17 at 18:23
9

I came here to just add more additional information. If you have troubles when install zsh in Amazon Linux AMI by Amazon, like when you run:

sudo chsh $(which zsh) : // chsh command not found

Then you should install util-linux-user:

sudo yum install util-linux-user

(by default Amazon Linux AMI only has lchsh, but I can not figure how it work).

Then run the following command, it should work:

sudo chsh -s $(which zsh) $(whoami)
  • Thanks! This worked for AWS AMI :) – Mayura Oct 20 at 23:31
5

On Ubuntu, inside GNOME terminal, making changes via chsh won't have the expected effect...

To get over this problem, do this:

  • Right click in terminal
  • Profiles -> Profile Preferences
  • Under "Title and Command" tab, tick "Run a custom command instead of my shell" and provide the path to zsh executable.
  • Restart Terminal.

Peace.

P.S. Don't have 10 reputation to post images, so all texty instructions. :)

  • You have the rep you need now. :P – pradyunsg Mar 21 '16 at 8:43
0

one line

sudo chsh -s $(which zsh) $(whoami)

Extra Info: after that you'll probably want to do this ones

git clone https://github.com/zdharma/fast-syntax-highlighting.git \
  ~/.oh-my-zsh/custom/plugins/fast-syntax-highlighting

git clone https://github.com/zsh-users/zsh-autosuggestions ${ZSH_CUSTOM:-~/.oh-my-zsh/custom}/plugins/zsh-autosuggestions

nano ~/.zshrc 

find plugins=(git) Append zsh-autosuggestions & zsh-syntax-highlighting to plugins() like this

plugins=(git zsh-autosuggestions fast-syntax-highlighting)

source ~/.zshrc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.