This morning on my Ubuntu 10.10 system when I open a window - for example, system->preferences->about me, if I click in to a field such as "work email", I can no longer close the window with the mouse! Clicking the X on the window will not work.

Also, I loose the ability to click on anything else - clicking on the desktop, icons, menus, workspaces, etc. do not work. Even the effect when you hover over a folder on the desktop and that folder highlights - that stops until the window is closed.

If I open this same screen but do not click in to a field, everything is fine - I can close the window with the X and everything else works fine.

Same thing happens with several other windows I tried. Even calculator - I can open it, everything is fine until I click on a button in the calculator - then no ability to click on anything else. Have to Alt-F4 to close the window.

The system is only about a week old from a fresh install (64 bit ubuntu - quad core amd machine).

I uninstalled wine, turned off remote desktop/disabled in startup, also in startup disabled visual assistance, bluetooth, dropbox, klipper. Reboot, no difference.

The only other thing non-standard I see in startup is nvidia.

Using a logitec usb mouse, saitek usb keyboard.

Was working fine yesterday. I can not think of anything I did / installed yesterday.

I switched themse, then went to update manager and saw two x server / x org related updates and installed them, reboot and NOW IT IS FINE!

However, then I re-enabled dropbox, klipper and remote desktop rebooted and the problem is back. Again I disabled and rebooted. Problem is still there!!

So somehow I fixed it at least for a few minutes, but now it is back and I am out of ideas.


Thank you for responding, I did end up figuring it out, though it still does not make sense.

All I had to do was unplug the mouse from the usb port and plug it back in.

It is a logitec wireless laser mouse. The wireless base has a power cord and a usb cord. Pressing the reset buttons on the base and mouse has not impact. I even turned off the mouse and back on and unplugged / replugged power to the base.

Finally I decided to pull the machine out and unplug the base - and plugged it back in. Problem fixed!

I just think it is very strange, because it does not seem like a hardware issue.

I mean, why would opening calculator, clicking on a number then prevent me from being able to click on the close box of the window, or anything else - desktop or system menus? Yet I can still click other buttons within the window!

Anyway at least I figured it out and I know what to do in the future, just very strange.


Sounds weird, indeed.

Have you tried disabling compiz?

Go to "System" -> "Preferences" -> "Appearance" -> Tab "Visual Effects" and select "None".

You could also try to reconfigure metacity and compiz like so:

sudo dpkg-reconfigure metacity compiz

Log in and out again and see if you're still affected.

But be warned: this removes all changes you've made to compiz'/metacity's behaviour (e.g. through ccsm).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.