For the last five hours I've been trying to install Microsoft SQL Server 2008, first on Windows 7 and then Windows XP. Both have had the same issue. Even before the installation starts, an error message appears saying:

Microsoft .NET Framework 3.5 SP1 installation has failed. SQL Server 2008 Setup requires .NET Framework 3.5 SP1 to be installed.

I have installed everything in the hope of getting past this. the service pack it refers to has even been installed and I can see them in the control panel!

I have installed Framework 2.0, Framework 2.0 SP1, Framework 3.5, Framework 3.5 SP1, Windows Installer 3.5 and Windows Installer 4.0. Even installed the Service Pack for SQL Server 2008.... But, nothing, works!

Does anyone have an idea what I'm doing wrong or what could be wrong? I'm seriously close to the end of my tether, I've even sent Steve Ballmer an email with my frustration. I would seriously appreciate some help with this.

  • Do you have any previous version of sql serve installed ? or visual studio ? – Shekhar Jan 12 '11 at 5:48
  • Not on the XP machine. That's a complete reinstall. On the Windows 7 machine I have VS 2010 installed, and had SQL 2008 Express but I removed that with no joy. – mickburkejnr Jan 12 '11 at 9:21
  • On the Windows 7 machine, you cannot install SQL Server after Visual Studio. See if that's the problem with that machine. Alternatively, your installation media may be damaged. – user3463 Jan 13 '11 at 16:53

Step 1: Remove all copies of the .NET Framework with this tool.

Step 2: Reboot the computer.

Step 3: Reinstall the .NET Framework from v1.1, v2.0, v3.0 to v3.5, but reboot in between each version, and run Windows Updates each time to make sure they're all up to date (may take several reboots).

Step 4. Install SQL Server.

  • On the XP machine I tried to uninstall v2.0 but it refused. It gave an error (I don't know what it was at the moment as I'm not at home now). I will try your answer when I get home. Cheers. – mickburkejnr Jan 12 '11 at 9:23
  • Yeah, this tool will fix that for you. – user3463 Jan 12 '11 at 20:43
  • I've followed all the above steps and its still the same. What's even weirder, I have tried to install SQL Server 2008 Express and this has installed fine. – mickburkejnr Jan 13 '11 at 10:50
  • See my response above. – user3463 Jan 13 '11 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.