20

I am unable to expand my Mac's hard disk. diskutility reports this error:

MediaKit reports partition (map) too small

How can I resolve this?

| improve this question | | | | |

11 Answers 11

16

If you start the GParted live cd: http://gparted.sourceforge.net/ On your system it will automatically detect and fix this issue. Best solution I found so far.

| improve this answer | | | | |
  • Nice. I guess most recent Macs use HFS+ (Mac OS Extended), which seems to be supported for checking a partition according to its feature overview. – Arjan Feb 2 '14 at 12:59
  • Worked like a charm--this is the best answer--needs more up votes. – scotru Apr 28 '14 at 7:53
  • works great. just boot from the live iso, start gparted, choose "fix" when the pop up shows, and then exit. – syonip Oct 14 '16 at 13:59
  • This worked great for me. In my case, my Macbook 4,1 (white, 2008) is set up to dual-boot, with the Mac OS Snow Leopard on the first partition, and Lubuntu on the second. I had difficulty booting from the Gparted disc I burned, but I installed Gparted on the Linux partition, and just ran it from there, reduced the partition size by about 300 MB, and after that Snow Leopard was happy to reinstall on the partition. – Pete Forsyth Jun 3 '19 at 5:33
  • This also worked for me using an Ubuntu Live USB. I already had that lying around and wondered whether I could avoid using up another USB stick, so I booted into Ubuntu and voila - GParted was already there. It may come bundled with other live distros too. – twm Jan 11 at 18:18
9

Try to format your disk from the Terminal using diskutil command, for example:

  1. List all drives:

    diskutil list
    
  2. Unmount the drive (replace diskN with your drive):

    diskutil unmountDisk force diskN
    
  3. Erase boot sector with zeros (make sure you won't erase the wrong drive!):

    sudo dd if=/dev/zero of=/dev/diskN bs=1024 count=1024
    

    Warning: Above commands wipes all data on /dev/diskN, so make sure you've it correct!

  4. Partition using diskutil:

    diskutil partitionDisk diskN GPT JHFS+ "My External HD" 0g
    

Source: Disk Utility fails to erase/format an external HDD at reddit.

| improve this answer | | | | |
  • 1
    this helped me: sudo dd if=/dev/zero of=/dev/diskN bs=1024 count=1024, thanks – GwenM Sep 6 '18 at 13:31
6

This blog post was the only way I found to solve it, and it's not for the faint of heart. ;-)

http://blog.scottmroberts.com/archives/15

Basically the problem is that the GUID partition table is confused about the size of the drive. The only way to fix it is to purchase a tool that will correct the problem, or to manually correct the problem yourself by issuing commands to gpt to delete and recreate the partition table. You must create it exactly how it was before, including the partition types (UUIDs).

Also, you must be able to get a root prompt where the drive you're interested in isn't mounted. (for me, this meant popping in the install disk, booting from it, then quickly pressing Command-S to enter single-user-mode.)

| improve this answer | | | | |
  • FYI, If gparted now supports this (see above answer), I'd do it that way! – mpontillo Sep 11 '14 at 18:10
  • Thank you! This was causing a nightmare for me. This solution worked out perfectly. – Tony Beninate May 21 '16 at 11:21
2

I know it is a late response. Now only I faced this issue and I find out this blog INCREASE DISK AND PARTITION SIZE IN OS X. This solved me my issue. I am posting this because this might help someone else I hope.

| improve this answer | | | | |
2

Why not just boot into single user mode? Hold down command+s on boot. Performcheck disk and then mount the drive.

Go to /Library/Caches and /System/Library/Caches and remove everything in those folders.

Then go to /private/var/db and remove BootCache.data, BootCache.playlist and .volinfodatabase. Reboot and use Disk Utility again. Just did this here and it worked moving from a 120GB SSD to a 250GB SSD. Was getting the dreaded medikit error too small or whatever.

You might just have to remove the .volinfodatabase. Try that first. If that doesn't work try the .volinfodatabase again and the BootCache files. If that doesn't work try what I tried.

| improve this answer | | | | |
  • This worked by removing both .../Library/Caches, and the BootCache.data + BootCache.playlist – bigkm Apr 7 '15 at 5:41
2

Not necessarily a useful answer, but I fixed this problem in Yosemite by using the Repair disk option in Disk Utility. Using OSX in virtualbox, on a virtualbox host, and I changed the dynamic disk size, but OSX wouldn't allow me to resize the partition (with the error in the original question)

| improve this answer | | | | |
  • 1
    Works On My Machine(tm)! – Grant Holliday Sep 14 '16 at 14:27
  • This worked for me and is the best answer, no messing around, just repair and then resize without any errors. Cheers! – NateS Apr 24 at 17:28
0

New in Mavericks apparently, you can boot from the installer media (cd or thumb drive) and use it's disk utility.

Steps:

  1. insert installer media
  2. Restart, keeping the option key held down until it asks you what media to boot from
  3. Select the installer media to boot from
  4. You will be presented with some options, the last of which is disk utility
  5. Open disk utility
  6. Partition as normal
  7. Restart normally

This works because it skips all the cached information about the drive that Jens Erat mentioned in his comment. You might notice that around step 5/6 disk utility will take some time to analyze your disk, which it doesn't do when you've booted normally. That's a good thing.

By the way, this does not work in recovery mode. Recovery Mode looks very similar to the booting from the install media. But recovery mode still boots off of the harddrive you're trying to repartition, and that causes problems.

(Thanks to Dennis at my job for helping me figure this out)

| improve this answer | | | | |
0

I was able to fix this issue by resetting the NVRAM (command+option+p+r at boot).

| improve this answer | | | | |
0

I had this problem when trying to remove some linux partitions from the disk. Reformatting them as MacOS partitions made it possible to remove them afterwards.

| improve this answer | | | | |
0

Perhaps a simple answer: I fixed this by using Disk Utility, erasing the drive and reformatting it to Mac OS Extended (Journaled), selecting the GUID Partition Map as the scheme. Once that had completed, I was then able to partition the drive successfully. Previously I had been attempting to format it to use an Apple Partition Map after which I kept getting the described error message when I attempted to split the space into two partitions.

| improve this answer | | | | |
0

If your HDD is shipped with the software, use it to format it, Or get from their site.

For example, I've WD My Password 4TB and it worked using WD Drive Utilities app.

WD Drive Utilities, Drive Erase, My Passport

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.