I've been trying to find a way to have a real equalizer for my Toshiba Satellite Pro Laptop. I don't know much about computers but the guys in the store seem to know less than I do! From what I've been able to glean through friends, Windows 7 no longer supports a real equalizer function with Realtek, and the result is a fake "equalizer" that does nothing. I have hearing issues so not being able properly adjust the higher frequencies is causing me physical pain and ringing in my ears. I've tried to decipher the threads I find online but am quite confused by them. Basically I need an equalizer that will work with Windows 7 (with everything, internet, skype, music, etc). The current drivers offered by Realtek do nothing except make the sound inaudible. The one that may possibly work and provide an actual equalizer is a few versions back and can't be found anywhere. Thanks! And sorry if this is a duplicate question but I am confused a bit by the threads online.


Breakaway Audio Enhancer may be the answer. It's not free ($30) but does have a 30 day demo so you can test it out.

Breakaway Audio Enhancer dramatically improves the audio experience for all PC users with the same technology as pros in the music business use to clarify and control your computer audio. Breakaway Audio Enhancer provides complete audio control over music, videos, web browsers, and games. Screaming web ads impale speakers, Hulu videos require cranking the volume up, and every media player makes favorite CD’s sound different but Breakaway Audio Enhancer changes all that. Audio from any source sounds professionally mixed with the Audio Enhancer’s automatic adjustment of volume dynamics and equalization.

enter image description here


I have a Toshiba Laptop and I was trying to accomplish the same thing with my speakers. I went into the control panel and clicked on the "more options" icon and it brought up a SmartAudio icon which had a terrific equalizer for my speakers! I hope this helped you!


For a quick fix, you can go to the "sound" window in the control panel and change the settings accordingly in your speakers properties. Granted it's not quite the same has having a full-on equalizer, but it may do the trick.


I found a solution to your problem. I have the same problem you have and I managed to fix it. What you want to do is go into your "Smart Audio" control panel and once that's opened, you will see a few tabs on the bottom. Click on the Large Speaker Equalization icon. (It should say "SmartEQ / 3D Settings") Now, once you're on that screen, you will see 7 small icons for tweaking..Select the "VOIP" icon and close that window. You should now hear the difference in sound.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.