13

Is is possible to force IP connections over the wired ethernet if it is connected and over wireless LAN if the wired ethernet is unavailabe (e.g. cable disconnected). Both network connections would be part of the same subnet.

5 Answers 5

17

You can set your laptop to "prefer" the Ethernet connection over the wireless. TechNet has a quick overview:

The short answer is that Windows (Vista, 7, 2008, and I’m pretty sure XP and 2003 does as well) [or should do] this by default. The key here is the network interface metric. When you have more than one default gateway defined [...] then the internet bound packets go out the interface with the lowest metric.

[...] You can, of course, permanently alter your metrics by editing your TCP/IP settings on your network adapter’s advanced settings.

[...] You should know that Vista made a change to how we handle existing sockets – after plugging in, connections will not be switched over, you must re-establish the connection in order to make use of a wired connection. For example, if you’re downloading something from a website and realize that it would go faster by plugging in, you’d have to cancel and start over after plugging in. This is a change from XP and 2003.

For how to change these settings, have a look at this Microsoft KB article.

2
  • Works like a charm... Jan 18, 2011 at 12:00
  • Thanks for the feedback. I know it takes a bit of tweaking but in the end it works.
    – tombull89
    Jan 18, 2011 at 12:32
4

The wireless network is not entirely disabled, but windows is already configured to prefer your wired network when available. This happens via the routing table. Your routing table will have an entry for both interfaces, but the metric for routes on the wired interface has a lower default than routes on the wireless, such that the wired network is checked first when evaluating where to send a packet. You can view your routing table by opening a command prompt and entering route print.

1

I found a different MS Support article helpful fixing this issue in Windows 7.

It basically explains that you can:

  1. Go to the Start menu.
  2. Type view network connections in the Search programs and files box.
  3. Choose View network connections in the search results.
  4. Press Alt and go to the Advanced Options > Advanced Settings... menu item.
  5. In the Advanced Settings window that opens, look for the Connections list at the top of the Adapters and Bindings tab, and use the up/down arrows to the right of it to change the priorities of your connections (from highest priority to lowest priority).
  6. Click OK to save your changes.

Below is a screenshot of a typical Advanced Settings window with a connection selected in the Connections list and the up/down arrows to the right of the list enabled accordingly:

Windows 7 'View network connections' -- 'Advanced Settings'

3
  • 3
    Does this actually work? Mine is set up correctly and I have seen this instruction all over the Internet yet my laptop still is connected to WiFi even if the ethernet is plugged in. Jul 28, 2015 at 13:05
  • @PeterTirrell: It worked for me on a Win 7 Pro 64-bit machine back when I answered; but I just noticed a situation on another Win 7 Enterprise 64-bit where it did not work: the routing metric was 20 for both the LAN and WLAN interfaces even though the LAN interface was bumped up in the Advanced Settings > Adapters and Bindings > Connections list as shown. To fix the problem I had to set the WLAN interface's routing metric to 30 (i.e. higher than 20). So your mileage may vary I guess.
    – J0e3gan
    Nov 18, 2015 at 0:53
  • Adapters and Bindings tab is missing! Dec 27, 2021 at 11:18
0

A good internet connection manager is Lenovo Internet Connection (AKA Lenovo Access Connections). With this tool you can create profiles, and have them in an order of preferred networks (i.e. wired over wireless, etc). The profiles you create can be exported and used on other computers.

-Good Luck

0

in my case, even I gave high priority on wifi, it was not still connect to internet. I checked wifi adapter settings and see an option something like "allow other network users to connect through this computer's internet connection". it was not selected. after I selected it, my computer could start using internet successfully.

go network settings -> choose wifi -> right click -> wifi properties -> sharing -> select "allow other network users to connect through this computer's internet connection"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.