I have a suspicion that the onboard IDE controllers may not be working. Every disk I use to setup this machine reports as damaged (using a win xp installation to test, since it gets to partition setup fastest)

So, I popped an IDE PCI Controller card in, to test with, but no drives are showing up in the bios now. I went into setup and changed the BIOS settings to disable onboard IDE1 and 2 to test, but still didn't detect the drives.

How do I get that working?

It's a standard PC with a 160GB disk and DVD Drive on master and slave channels on a single cable, if that helps. Let me know what else I need to state.


The motherboard's BIOS must have a setting for Option ROMs, SCSI Cards, or something along those lines; it must be disabled if your PCI IDE Card isn't showing up. It's also possible you already have 4 cards with Option ROMs, or some of those option ROMs take up more than one "slot" (keeping it simple...).

A side thought, the HD or DVD drive might have incompatibilities that don't allow them to both work on the same channel. Has this system worked before? This isn't likely, but one might be damaged or something like that too.

  • Couldn't find anything like that in the BIOS so far, there's no other PCI cards on there except the IDE controller, and a graphics card on a PCI-E slot. I'm trying different channels and cable combinations now to see if that might be the problem
    – mercutio
    Jan 17 '11 at 15:19

Most of the time it is a bad IDE cable, try a new 80 pin cable.

When you install a PCI IDE card it will have its own bios, it shoud post right after the motherboard bios, this is where you would see the hard drive that is connected to it be detected.

Older motherboard bios's may not support booting from the add in IDE PCI card, so you would not be able to boot from it even if you get XP installed on that drive.

With the card installed, check the motherboard bios, if you cannot set the add in IDE card as a bootable device or see it as a device anywhere, then your MB bios does not support booting from add in PCI devices.


Maybe there is a second bios of the pci-ide card? Sometimes choosing "scsi" option to boot from first does the trick.

Hope that helps.

  • SCSI to be choosen from the motherboards bios...
    – Stefan
    Jan 17 '11 at 14:39
  • Couldn't find any other options for doing that by looking around. Am experimenting with alternate cables and controllers now
    – mercutio
    Jan 17 '11 at 14:46
  • Another points... Have you jumpered the drives correctly?
    – Stefan
    Jan 17 '11 at 14:51
  • Yep, the DVD drive on slave and the HD on master. I'm trying both on master and different channels at the mo. Not much luck so far though
    – mercutio
    Jan 17 '11 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.