I have an netbook hard drive that won't boot or be mounted and is refusing to cooperate in my debugging. There were two partitions on the disk, an Acer installed recovery partition and my main XP one.

Summary: Only the 6GB recovery partition is mountable, and appears to be fine. Testdisk recreated the partitions, but can't read from the main one. Hitachi hardware diagnostics check out fine. Nothing I do seems to recognize a file system on the main partition. The master boot record seems to be problematic.

Environment: Acer Aspire One AOD150 netbook in original configuration. XP Home Premium, updated and current. Original Hitachi 5K320-160 hdd. BIOS 1.13. I don't have access to an external drive enclosure for now.

How it started: I was writing in a web form (Chrome) when the netbook locked instantly and completely (no pointer movement; ctr-alt-del did nothing). I held the power button down to reboot, and when it came back up, the BIOS started looping through alternate boot options. It said there was no boot disk, as if the hard drive wasn't connected.

Troubleshooting performed and results: Unseated and reseated the hard drive. No effect.

Booted to a Knoppix 6.4.3 CD. Hard drive was not visable to mount.

Ran testdisk (Intel option; NO to Vista partition question) which originally showed 4 nonsensical, overlapping partitions. The quick search found the 2 real NTFS partitions, and appeared to have the size correct. The deeper search showed the same results. The "p" command allowed me to view files in the recovery partition, but gave an error for the main partition "Can't open filesystem. Filesystem seems damaged." I switch the main drive to primary bootable. Even though it wasn't working completely, I wrote the partitions to disk.

Rebooted to Knoppix. It can now see and mount the PQSERVICE recovery partition. I can't browse to the main partition, but fdsik -l shows both partitions. The Disk Utility shows the 160GB drive as healthy, but only finds the one 6.4GB partition.

GParted shows both partitions plus 2.49 MiB unallocated, but gives a bunch of warnings for the main: "$MFT had invalid magic. ntfs_mft_load():Failed. Failed to load $MFT: Input/output error. Failed to startup volume: Input/output error. Failed to mount '/dev/sda2': Input/output error. NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!" I then tried "Check and repair filesystem (ntfs)..." in GParted. Same error as above.

Booted to Ultimate Boot CD UBCD 5.0.3. Ran the Diagnosis Drive Fitness Test v4.16 for the Hitachi drive. Both the quick and full scans completed without error.

Used Smart BootManager to boot to the PQSERVICE recovery partition (Alt+F10 isn't working). It loads fine. I'm not yet willing to try to recover to factory defaults and sacrifice my data.

Ran MBRtool and MBRWork, rebooting after each. Now the BIOS says "A disk read error occurred press Ctrl+Alt+Del to restart".

Booted to UBCD4Win 3.60. Ran chkdsk /r on the recovery partition, without error. chkdsk would not run on the main partition.

Originally I couldn't boot to a Windows Recovery Console CD. It blue-screened giving a STOP 0x0000007B error that the drive wasn't accessable. I went into the BIOS and changed the hard drive interface from AHCI to IDE. I can now boot to the Recovery Console.

Ran chkdsk again, same results as before.

Ran fixboot and rebooted, no change.

Ran fixmbr and rebooted, no change.

But in IDE mode, I can't see the recovery partition anywhere. I have to switch it back to AHCI to view it in Knoppix or get testdisk to recognize the drive.

Plea for help: I would really like to know what's going on. Is it a hardware problem that isn't detected by SMART or the Hitachi diagnostics? Or is it just a bad MBR that I can't seem to get right? Is my best bet to give up on the data, reformat, and reinstall? Or is there something more I can try?

Thanks much!


On a hunch, I went back and reran testdisk, choosing to search for Vista partitions even though it's an XP install. The quick search showed no improvement, but the deeper search uncovered the deleted ACER partition. After writing to disk, the computer rebooted into XP as if nothing had ever happened.

I'm running chkdsk now just to be safe, but it seems to be back to normal. Hooray!

  • If you can see anything with AHCI stick with that...you could try manually specifying offsets and length to force the mount from live media...it's a last ditch thing though. when it comes down to it you could always image the entire disk to a file somewhere else and do the file carving on an old pc (be prepared for file carving to take forever though) you might have had a head crash somewhere critical. – RobotHumans Jan 18 '11 at 4:25
  • 1
    This is the point where I decide whether professional data recovery is worth the loss of data, and send it to the professionals. – user3463 Jan 18 '11 at 6:12
  • Low Cost professional Data Recovery...lowcostrecovery.com/pricing.html – Moab Jan 18 '11 at 14:15
  • The data lost definitely isn't worth the price of pro recovery. It's probably not worth the time I've already spent troubleshooting the drive. But before I sink a day into reformatting and reinstalling everything, I'm hoping there's something else that might recover the filesystem. And I'd like to know what went wrong, to give me an idea if it's a hardware or software failure. Thanks for all the replies so far. – ChrisJ Jan 18 '11 at 19:34

A friend dropped her Acer Aspire One KAV10 on the ground while it was still powered on and it restarted with "No boot device found" "PXE-M0F" etc. Your problem seems similar but your solution wasn't really that intuitive so I'd like to elaborate on what I did to fix it.

I burnt a copy of UBCD511, booted into Parted Magic (using defaults), opened xterm and used TestDisk to:

  1. Restore the NTFS boot sector
  2. Recover the ACER partition table

Recovering an NTFS Boot Sector from an NTFS Partition using its backup

From TestDisk:

  • [No log]
  • Select disk
  • [Intel]
  • [Advanced]
  • If "Sectors are not identical." appears then:
  • [BackupBS]

[q] to return to the previous menu

Recovering the ACER partition table

From TestDisk:

  • [No log]
  • Select disk
  • [Intel]
  • [Analyse]
  • [Quick Search]
  • [Y] for Vista (just default it to Y)

It should have something like:


  • Use [up]/[down] arrows to select the non-PQSERVICE partition
  • [p] to list the files
  • If the list of files looks complete messed up then go back to the list of partitions by pressing [q]
  • [Enter]
  • [Deep search]
  • After about 1,000 cylinders have been searched you should have about 3-4 partitions listed. If so, press [Stop]
  • Use the [up]/[down] arrows to select the PQSERVICE partition
  • Use the [left]/[right] arrows to change the type from * (boot) to P (primary)
  • Use the [up]/[down] arrows to select the ACER partition
  • [p] to list the files
  • If the files don't look ok then go back with [q] and look at another partition
  • If the files look ok then [C] copy the files to an external hard drive if you want to
  • Use the [left]/[right] arrows to change it from D (deleted) to * (boot)
  • [Enter]
  • Confirm and reboot

Windows XP should now load.

I'm posting this for the benefit of others if they find themselves in a similar situation, and as a reminder if I've to do this again.



Have you considered SpinRite by GRC?

It allows low level access to almost all types of hard drive partition.

The cost is $89.

  • 1
    Steve Gibson is that you? :-> – Moab Jan 18 '11 at 14:14
  • SpinRite level 2 scan showed nothing out of the ordinary on any of the partitions. It really does seem like the only thing wrong is that testdisk is writing a bad partition table. Can anyone suggest a tool or method to address that? – ChrisJ Jan 19 '11 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.