A user (lets call him Peter) in our domain cannot activate a given COM component. Other users on the same client are allowed to this. Peter is not allowed to do this from other clients, too.

The error log shows this message (in German):

Durch die Berechtigungseinstellungen (application-specific) wird der SID (S-1-5-21-2673674691-2724651309-2952049826-1211) für Benutzer BBC\guenther.weerts von Adresse LocalHost (Using LRPC) keine Berechtigung zum Activation (Local) für die COM-Serveranwendung mit CLSID 
{7D1933CB-86F6-4A98-8628-01BE94C9A575} und APPID  {F290BFB2-1864-45B1-8804-2654194A87E7}

Roughtly translated: By the right configuration (app specifc) the SID (...) for user .... from address localhost (using LRPC) has no rights to activate (local) for the com application with clasid ... and appid ....

Any Ideas where to look?


Problem solved... the user was logged on onto a Citrix machine which hadn't the component installed.

  • 1
    Glad to see you figured out your problem! Please remember to mark your own answer as accepted once enough time has passed to allow you to do so. This will let other users know that the problem has been solved. Thanks. – nhinkle Jan 19 '11 at 7:44
  • I already tried, but the problem solved itself too fast :) – Daniel Jan 19 '11 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.