2

I just installed auctex and preview-latex on my mac, and now when I open a tex document I see auctex has been loaded, but when I try to generate a preview I get the following error message:

Running `Preview-LaTeX' on `writeup' with ``latex  "\nonstopmode\nofiles\PassOptionsToPackage{active,tightpage,auctex}{preview}\AtBeginDocument{\ifx\ifPreview\undefined\RequirePackage[displaymath,floats,graphics,textmath,sections,footnotes]{preview}[2004/11/05]\fi}" "\input" writeup.tex''
/bin/sh: latex: command not found

Preview-LaTeX exited as expected with code 127 at Tue Jan 18 20:01:34
LaTeX: LaTeX found no preview images

What is going wrong here? LaTeX is in my path, at least at the terminal. For Emacs when I run M-x getenv PATH I don't see the LaTeX installation in my path. I created a file ~/.MacOSX/environment.plist with the following lines:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd";>
<plist version="1.0">
<dict>
<key>PATH</key>
<string>/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/texbin</string>
</dict>
</plist>

But that didn't change my PATH variable in Emacs.app at all.

2

Emacs internally uses the exec-path variable to determine what it looks for.

This is normally initialised to PATH, but not if it is customised. Check its value using c-h v exec-path; there's a link there to the customise submenu. If you delete the relevant line from your customisation file (see the value of the Emacs variable custom-file), you can force the default behaviour.

| improve this answer | |
  • My custom.el just has two calls in it: (custom-set-variables) and (custom-set-faces) But the path I see when I look at exec-path is different from the PATH. – 2daaa Jan 20 '11 at 19:03
  • What happens when you setq exec-path in your Emacs initialisation file? – Charles Stewart Jan 20 '11 at 19:29
  • Actually it seems to be working now. I rebooted my computer and that seems to have caused Emacs.app to start reading the environment.plist file. – 2daaa Jan 20 '11 at 20:00
1

You need a LaTeX installation. Make sure the directory where the latex executable lives is inside your PATH.

| improve this answer | |
  • Sorry I should have been clearer. There is some kind of PATH problem, but I do have LaTeX installed and I can run it from the terminal just fine. Emacs.app isn't aware of it for some reason though. – 2daaa Jan 19 '11 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.