I'm behind a slow connection (Dial Up) with high latency (+400ms). I have recently received a broken MyBook World, which I refurbished and I have Debian installed on it.

The problem is, that this device doesn't have a build-in clock, so at every boot the date is set back to 1970. I though I could solve this using NTP, but NTP runs, but exits after a while, without errors and with the same time. I was using ntp -q.

I also tried ntpdate-debian, which gives the following error:

1 Jan 00:14:11 ntpdate[966]: no server suitable for synchronization found

Here's my ntp.conf:

root@mybook:~# cat /etc/ntp.conf
# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>

server ntp1.belbone.be iburst dynamic
server ntp2.belbone.be iburst dynamic

server ntp3.linocomm.net iburst dynamic
server ntp2.linocomm.net iburst dynamic
server serv01.richs.nl iburst dynamic
server ntp.grafix.nl iburst dynamic

# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict mask notrust

# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth


As you can see, I also tried selecting the servers which are geographically close to me (Belgium).

If anyone could offer some help?


Try using ntpdate before ntp. You can also use the ntpq -c peers command to see if you are connecting to your servers. I typically use my ISPs time servers or dns servers if possible. It looks like you may be doing this. These should have good connectivity and lantency.

ntpdate -d ntp3.linocomm.net can be used to check for connectivity. You can list all your servers in one command. Remove the -d to set the time.

| improve this answer | |
  • Thank you, but I solved the problem by CURLing a date from a script on my Web Server. The date accuracy is not important, but this is an embedded device without internal clock, so every time it boots the date is set back to 1970. The device mostly operates behind a 3G router, that explains the high latency values. – friedkiwi Jun 1 '11 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.