10

As of a couple of months ago Windows has started detecting a 2nd "generic non PNP monitor" that is supposedly connected to my laptop. I wouldn't mind this but it's causing problems when I actually do try to connect another monitor. I wasn't able to find any info on the matter and was wondering if anyone else has encountered this problem.

I tried uninstalling the ghost monitor from the device manager but windows somehow "detects" it once again after a while.

I have an NVIDIA GeForce Go 6150 graphics card with the updated drivers and using windows 7 ultimate.

  • What does win+P do? – James Mertz Jan 20 '11 at 3:27
  • @KronoS Pressing Win+P allows one to use the Windows 7 Multiple monitor dialog to cycle through the different output options (clone, extend, second only, first only). – twobob Oct 19 '18 at 22:16
4

This may well be a hardware issue.

The presence of a "non-PNP" VGA monitor is detected by just sensing electrical load on the RGB/HV outputs, so a faulty driver chip or short-circuited board can cause misdetection.

If this is the case, having the video card replaced will fix the problem.

| improve this answer | |
  • 1
    Is there is any alternative solution that this. Mine is a laptop and has same issue. – Starx Oct 16 '11 at 6:39
  • 1
    But make sure to try @twobob's answer first - it worked flawlessly for me. – Marcus Mangelsdorf Jul 21 '16 at 10:55
17

Choose main display. Ensure it is "1"

Choose "Show Desktop Only on 1" from drop-down. (hit "Apply")

Choose errant display (which is now grey, not blue) Choose "Remove this Display"

Screenshot with remove this display

| improve this answer | |
  • 3
    The problem is that there is no such an option as "Remove this display" in this dropdown for the ghost monitor. – thorn Mar 17 '16 at 21:09
  • 4
    Remember to hit "Apply" after choosing to "Show Desktop Only on 1". Then the option to "Remove this display" shows up on the list – papacito Jan 19 '17 at 8:46
  • 1
    I'd been struggling with this for a few hours. Couldn't get the ghost monitor to go away. Would normally have ignored it but once in a while things would open on the ghost. This solved the issue. I tried everything else but the "show desktop only on one" and then the disconnect device option was there. THANK YOU! – user1759942 Jul 5 '18 at 13:47
2

In device manager uninstall all the monitors in there and uninstall the video card, reboot the machine. Reinstall drivers if applicable (I didn't have to when I had this problem). I remember what a pain it was when I was having this issue.. it took me a while to figure out it was the second "ghost" monitor. I wonder if it is only affects people running windows 7? I have not seen this on XP.

| improve this answer | |
  • 3
    i tried that but it just "re-detects" the ghost monitor after a while... – yurib Jan 19 '11 at 23:24
  • Damn, sorry that's all I had, it fixed the problem for me. I had like 4 pnp monitors in there too... – Supercereal Jan 20 '11 at 13:26
  • This issue affects all version of windows using that exact control dialog version only – twobob Jul 9 '18 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.