Error 4112 shows up when I select my language level. (German 1 or French 1)

I think it's also like this for the other levels.

enter image description here

What is causing this and how can I fix it?

  • Did you talk to their support? – Shinrai Jan 20 '11 at 17:10
  • 1
    Couldn't reach them! – ChristianM Jan 20 '11 at 18:07

Erorr 4112 can be fixed, it indicates that the language file is corrupted.

The only fix I could thus suggest is to reinstall the languge file (and software) to get rid of corruption...

Heh... I should get back to practice Italian with Rosetta Stone, long time ago.

  • God, I reinstalled and now I have another error when I try to add the language packs: Error 9118 – ChristianM Jan 20 '11 at 18:35
  • 1
    @ChristianM: Sorry, we can't keep helping you solve different errors that have no meaning to us. Please take time to Google for them to see if you can find an explanation, as far as I did I didn't see anything useful reagirding that error. The only thing that can still help is the Rosetta Stone Support or any log files that the application creates, you might also consider trying to install the software on a different computer to see if there is something wrong with your Windows installation instead. Yes, their language system isn't written that good, had similar issues but reinstalling worked. – Tom Wijsman Jan 20 '11 at 18:57
  • I'm sorry I couldn't give more information on the errors! Anyway, I found version 3.4.5 on TPB and it's working fine. Thank you for your help! – ChristianM Jan 20 '11 at 19:17

Just run it as Admin

if this didn't work then go to C/programdata/rosettastone and backup tracking.db3 to your desktop,and delete the original then run the program as Admin, then close it then delete the new tracking.db3 and replace it with the one you back upped in your desktop and voile!


I had the same prob. Since there's very little on the internet, I've pasted the gist of the live chat that helped me resolve the issue below.

Me: Hello. Thanks for helping me today. I have Espanol LA 1,2, and 3 on Windows 7. I am getting error code 4112 after I try to load my already activated and updated product. I tried uninstalling and reinstalling and I am still getting 4112.

Tech: Click on Start->Click on Computer->Click on C: Do you see program data folder?

Me: no

Tech: Then click on the organize on the top. Then click on folder and search options. Then click on the view tab.

Me: ah. show hidden files folders and drives

Tech: Yes. Have a check on it, click ok. Now you can see program data.

Me: now i'm able to get into program data, rosetta stone, then Totale

Me: now i see the file dynamic stored paths

Tech: Delete dynamic stored paths in Rosetta stone and TOTALe folder

Me: done

Tech: Close all the windows and open the program

Tech: Do not click on any user name. Insert the language level cd in the drive.

Tech: Please click on the icon next to the question mark with small lines

Me: yes

Tech: you can close the windows which shows the files of the cd.

Tech: Click on add/remove languages

Tech: Click on add a language level

Tech: right. done. Now it says: A newer version of this language level already exists on your computer. Are you sure you want to overwrite?

Me: Perhaps it's just referring to updates that were made when I had installed it before?

Tech: Yes. Over write

Me: installing

Tech: Install all three levels with your three discs and their updates

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.