In one of my photo folders, I have a 3.8 GiB TIFF image file. With automatic thumbnail generation set, explorer completely locks up my system when accessing the folder. By inspecting the Resource Monitor, I was able to see that explorer was trying to read the TIFF file at normal priority. Disk IO was thus locking up the system. Also, the memory consumption of explorer grew huge (more than available RAM), so the system was also trying to access the pagefile at the same time it was trying to read the TIFF file.

I had to force a shutdown to get back to my system. I turned off the thumbnail setting and I was now able to look inside the folder. But as soon as I single clicked on the file, explorer tried to read the entire file and locked up the system. I assume the right hand side quick preview was responsible for this lockup.

Can I specify a maximum file size that Windows should not attempt to thumbnail like in Adobe Bridge? Any other suggestions?

  • This I must try with Directory Opus, to see what happens... ^^ Aug 17 '09 at 7:19

You can disable thumbnail generation for only .tiff files, but this cannot be done by file size as of yet. The key is located at:


Simply delete the {BB2E617C-0920-11d1-9A0B-00C04FC2D6C1} key. You will want to back up the key first to restore this functionality if you want it back later on.


I'm not sure you can specify a "maximum filesize" for Windows' preview generator. I think the only way you can keep your system from freezing up is to disable previews entirely for that folder.

Here's the link for disabling previews in Windows XP: http://www.pctools.com/guides/registry/detail/1207/

And here's the link for disabling previews in Vista: http://www.howtogeek.com/howto/windows-vista/disable-thumbnail-previews-in-windows-vista-explorer/

I think Windows 7 has the same Explorer options as Vista, but I'm not sure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.