Sometimes, when I select a click a program on the Windows 7 taskbar it won't appear (it doesn't gain focus and remains behind other open windows), and the icon will flash and turn orange. This happens reasonably frequently, and I've had it happen on two separate Windows installs on different machines. It just happened now and the only programs I have with active windows are Chrome, WMP and Explorer (2). It happened when I clicked Explorer.

Once this has happened to one window, it affects all windows, and the only way I can switch between programs is by finding the window manually or using Windows+Tab. The only way I've come across to get the computer to snap out of this annoying behaviour is to restart the machine. Is there a way of stopping it?

  • Could you try to close some programs from the tray? They may be interfering with the normal behaviour of the taskbar. I've also read that having certain usb devices connected during startup may cause the problem. – Geeklab Mar 25 '11 at 20:02
  • Which USB devices? I'd be interested to see your source for that information. – fredley Mar 25 '11 at 22:02
  • 1
    I think this is a bug in Explorer... it's happened to me too, randomly. – Mehrdad Feb 4 '12 at 22:35
  • 1
    This appears to be focus stealing prevention not working correctly in Windows 7. This isn't exclusive to Explorer but is likely to be a problem with the Desktop Window Manager. – bwDraco Feb 5 '12 at 3:52
  • 3
    I had this problem, and it turned out that a systray menu was opened but not closed, and closing it fixed the problem. For me, it was "Apache Monitor" -- I had accidentally opened the context menu and then somehow left it open, and this caused the flashing buttons problem. Once I discovered it was open, I was able to close it and the problem went away. – ken Nov 27 '12 at 21:34

Ah, that video makes it more clear and even your mouse cursor icon seems to have issues, I would suggest:

  • Try updating video drivers.

  • Try disabling/enabling the Desktop Window Manager service.

  • Try disabling/enabling Aero.

  • Use ShellExView and try to disable non-Microsoft shell extensions, one might be bad behaving.

  • Try creating a new user account and migrating your stuff there.

As a last resort, I think you might need to reinstall...

  • 1
    The mouse cursor icon is just due to the recording software I'm using, normally it's fine. I have the latest drivers, and restarting explorer/dwm doesn't make the problem go away, only a restart fixes it. – fredley Mar 26 '11 at 11:26
  • And the other suggestions? – Tom Wijsman Mar 26 '11 at 12:14
  • 1
    It hasn't happened for a while, and I don't know what causes it so can't reproduce the error. When it happens again I'll let you know. – fredley Mar 26 '11 at 12:18

An anonymous (unregistered) user calling himself “Jonathan” tried to post the following:

The problem might be due to extended desktop you have. I tried to disable the other defined desktops and screens, but it didn’t help. Only after disabling the other screen through my video-card menu was the problem was solved.

(but he couldn’t, because the question is protected).

protected by harrymc Aug 24 '12 at 14:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.