I have a dev server on port 8080 on my mac, and I'm trying to access it from a clean installation of Windows 7 in parallels.

Ipconfig says my VM's IP address is I can access the mac web sharing service at but not my own webserver (GAE) at

  • Parallels set to Shared Networking and is able to browse the internet fine
  • Firewall is off in both windows and mac
  • I installed bonjour for windows as a few forums said to do. I can then use my-computer-name.local/ but same deal as before, port 8080 doesn't work
  • Tried adding a port forwarding entry of 8080,TCP,,8080 to Parallels Desktop > Preferences > Advanced > Port forwarding rules

2 Answers 2


Can you access your testing server on :8080 from other real machines on your network? It could be that your development server software accepts only connections from your local machine ( aka localhost).

  • 1
    Thanks, that was it. For appengine I needed to use the flag --address= for it to accept connections from any IP. Jan 26, 2011 at 4:07

Jake's answer worked for me, too. On jboss, just start the server with


and access it via


Note: no need to use "local"

Related: Access localhost on Mac OS X from Parallels machine

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .